Building error with android

  1. SDK Version 44.0.2:
  2. Platforms(Android/iOS/web/all): Android

Hello i have problem with building react native app. First i started with managed workflow and builds were nice, after that i switch to bare workflow and with iOS my build is also fine, but when i tried to build Android i get this error :

If somebody met this problem, i will be very happy if share solution. Thanks

Hey @toninikolaev23, based on the error it looks like a Java Runtime couldn’t be found in your environment. I’d recommend taking a look at the docs for setting up your Android development env Setting up the development environment · React Native

1 Like

Hi @toninikolaev23

I’ve installed JDK 11 on a Mac as follows. This seemed easiest for me:

I first installed Homebrew.
I then used that to install the temurin11 package which contains the Java development kit needed to build React Native apps locally.

1 Like

Thanks guys. The solution was exactly with Java. Before starting with React Native i had Java 18 and tried to downgrade to 17 and 16. And after that i remove all packages and install with homebriew temurin11 and everything builds :slight_smile:

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.