Admob banner is not displaying at all

Please provide the following:

  1. SDK Version: 37.0.10
  2. Platforms(Android/iOS/web/all): Android

My AdMob banner is not displaying anything except a white box. I put it in my app.js

<View style={styles.container}>
        {Platform.OS === 'ios' && <StatusBar barStyle="default" />}
        <AppNavigator />
          onDidFailToReceiveAdWithError={(error) => console.log(error)}

That ad unit ID is the test one for banners from Google. I also tried the ad unit ID of my own ad unit, but it also does not work. It correctly allocates the space for the ad, but it always just shows a white box. It does this both on the Android Studio emulator and my physical device. It also does the same in the apk. Here is the relevant part of my app.json:

"android": {
      "config": {
        "googleMobileAdsAppId": "myappID"
      "package": "my.package",
      "versionCode": 1

I can confirm that my app ID is correct. I have also created this ad unit more than a month ago and it is enabled. My payment details are all correct and I have been receiving payments on ads for other apps so I can confirm that is set up correctly. Since I am getting no error message from onDidFailToReceiveAdWithError, and the fact that the ads are not showing up with the test ad unit ID or my own ad unit ID, I am stuck.

I have tried to do a test interstitial ad, and it worked fine. With only the banner am I having issues.

I can’t seem to find a solution at any of the other threads with similar topics either. Thanks in advance!

it can take 24 hours for them to show up. if it’s been this long, you may want to reach out for support from google

It’s the same result with the test AD unit ID from Google so I don’t think it’s an issue with the ads populating, since the test AD should definetly fill

did you create it within 24 hours of trying to use it?

I created the ad unit in admob and tried to use it in the AdMobBanner immediately about a month ago but that had the same issue. After a month still no ads getting filled with my own ad unit id. I’m not using my ad unit id right now, I’m just trying to get the test ad unit ID to display something just so I know it works but it’s not showing anything. The adUnitID I put in the code I pasted is from the sample ad unit

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.