2FA not supported for Apple Developer Account for exp build:ios

It seems like the exp build:ios doesn’t work if your Apple Developer account has 2FA enabled. I disabled the 2FA and was able to get the build successfully started. Is this a known issue?

Please see below for (sanitized) logs. Thanks in advance!

➜ yarn git:(master) exp build:ios
[exp] Making sure project is set up correctly…
[exp] Your project looks good!
[exp] Warning: ‘react’ peer depencency missing. Run npm ls in /Users/wchen/yarn to see full warning.
[exp] If there is an issue running your project, please run npm install in /Users/wchen/yarn and restart.
[exp] Checking if current build exists…

[exp] No currently active or previous builds for this project.
[exp] Checking for existing Apple credentials…

We need your Apple ID/password to manage certificates and provisioning profiles from your Apple Developer account.
? What’s your Apple ID? my@email.com
? Password? ***********
? What is your Apple Team ID (you can find that on this page: Sign In - Apple)? #######
[exp] Validating Apple credentials…
[exp] Error validating credentials. You may need to clear them (with -c) and try again.
[exp] Unable to validate credentials: Internal error occurred. Please try again in a few minutes or contact support.


Yes this is a known issue. I think @dikaiosune is going to work on fixing this soon.

1 Like

Were you able to get a build; I doubt as by looking ta your last few lines of question. I am having same Issue :frowning:

@kantharia we don’t support Apple 2FA right now, so you’d have to disable it before creating a build. If you don’t want to do that you can build manually following the instructions here: https://github.com/expo/expo#standalone-apps

1 Like

still didnt worked for me :frowning:

Going to need more information than “didn’t work”! If you have an error message feel free to post it here.

Apple now supports only 2FA, some plans to implement this feature?


@dflourusso we’re actively working on 2FA support. Definitely realize this is a big issue right now.


2FA released https://github.com/expo/expo/issues/160#issuecomment-348375652

1 Like

I still cannot get 2fa to work (with exp or expo-cli). I do not receive a verification code (I receive it when logging into apple platforms, but there may be a problem bc there are two phone numbers associated with the account, so the apple platforms have an additional prompt for me to choose which). Additionally, I tried that --local-auth option mentioned in the issue, but it throws an error, claiming it is an unknown option.

Same issue here not asking for validation code help please