expo build:ios stuck with 2FA

I recently installed expo-cli with npm. The version I’m running is 2.11.8.

When I run expo build:ios the stacktrace is the following:

Checking if there is a build in progress...

Please enter your Apple Developer Program account credentials. These credentials are needed to manage certificates, keys and
provisioning profiles in your Apple Developer account.
The password is only used to authenticate with Apple and never stored.
? Apple ID: email@domain.com
? Password (for email@domain.com): [hidden]
⠋ Trying to authenticate with Apple Developer Portal...

Upon entering my PW, I get a pop-up to allow access from the device via Apple. I then see the window with a 6-digit 2FA verification code, however the CLI does not ask for a verification code and hangs indefinitely with the “Trying to …” message.

I tried generating an app-specific password via the Apple ID management portal, but this did not work (auth failed).

Please help <3

Same issue here. Apple forced me to enable 2FA and now nothing works. Never gives me the chance to input the verification code.

1 Like

Updating to the latest expo-cli fixed this for me.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.