Xcode 14 error Build input file cannot be found

I’m unable to create app variants using Xcode 14. I followed the instructions provided on the doc link. However, when I tried to build the app, the following error appeared:

Build input file cannot be found: '/Users/ma/Documents/dev/LNfound/mobile/ios/Pods/Target Support Files/Pods-LnFound/ExpoModulesProvider.swift'. Did you forget to declare this file as an output of a script phase or custom build rule which produces it?

I tried cleaning the build and deleting the derived data, but unfortunately, none of those worked

Has anyone faced this problem ? Have you any solution or workaround ?

Thanks in advance

reproducible example


expo-env-info 1.0.5 environment info:
OS: macOS 13.3.1
Shell: 5.9 - /bin/zsh
Node: 16.20.0 - ~/.nvm/versions/node/v16.20.0/bin/node
Yarn: 1.22.19 - /usr/local/bin/yarn
npm: 8.19.4 - ~/.nvm/versions/node/v16.20.0/bin/npm
CocoaPods: 1.11.3 - /Users/ma/.rvm/gems/ruby-2.7.5/bin/pod
Platforms: DriverKit 22.4, iOS 16.4, macOS 13.3, tvOS 16.4, watchOS 9.4
Android SDK:
API Levels: 29, 30, 31, 32
Build Tools: 29.0.2, 30.0.0, 30.0.2, 30.0.3, 31.0.0
System Images: android-29 | Intel x86 Atom_64, android-30 | Google Play Intel x86 Atom
Android Studio: 2022.1 AI-221.6008.13.2211.9619390
Xcode: 14.3.1/14E300c - /usr/bin/xcodebuild
expo: ~47.0.14 => 47.0.14
react: 18.1.0 => 18.1.0
react-native: 0.70.8 => 0.70.8
eas-cli: 3.13.0
expo-cli: 6.3.8
Expo Workflow: managed

I got the same issue. Did you find the solution?

Found solution xcode - React Native Production Build Error ('Build input file cannot be found: {path}ExpoModulesProvider.swift') - Stack Overflow

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.