SDK 29 Ios Build Error

I Tried:

$ rm -rf ios
$ exp detach
$ cd ios
$ pod install
[!] CocoaPods could not find compatible versions for pod "ExpoKit/GL":
  In Podfile:
    ExpoKit/GL (from ``, tag `ios/2.7.0`)

None of your spec sources contain a spec satisfying the dependency: `ExpoKit/GL (from ``, tag `ios/2.7.0`)`.

You have either:
 * out-of-date source repos which you can update with `pod repo update` or with `pod install --repo-update`.
 * mistyped the name or version.
 * not added the source repo that hosts the Podspec to your Podfile.

Note: as of CocoaPods 1.0, `pod repo update` does not happen on `pod install` by default.

I Also Tried Tried, create New App in XDE SDK 29:

$ exp detach
$ cd ios
$ pod install

Result Error

[!] Invalid `Podfile` file: `${' is not allowed as a global variable name
/Users/i9xp/Documents/GitRepos/my-new-project/ios/Podfile:14: syntax error, unexpected end-of-input, expecting keyword_end.

By Removing Erred Line come back to First Error.

1 Like

Some help Here? @esamelson, @jesse

1 Like

@victorwads I was getting the same error.

Fixed by making my Podfile look like this (linked in the new blogpost for sdk29):

And as a heads up, I also had to I had the paths in that from “…/node_modules/expo/node_modules/” to “…/node_modules/”

1 Like

Thank U @valpe70! It Solve My Problem!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.