upload:ios failed


I have tried to upload my app to Testflight using ‘expo upload:ios’ command, but I received the following error message:

Ervins-MacBook-Air:amigo-shop-mobile ervinbalazs$ expo upload:ios
? What’s your Apple ID? **@.com
? Password? [hidden]
Downloading build from https://exp-shell-app-assets.s3.us-west-1.amazonaws.com/ios/%40smartitory/amigo-shop-mobile-325f9606-e2f7-40d8-8fe6-bc148daebbcf-archive.ipa
Downloading [======================================================================================================================================================================] 100% 0.0
Resolving the ITC team ID…
Failed to upload the standalone app to the app store.
undefined method `’ for nil:NilClass
Set EXPO_DEBUG=true in your env to view the stack trace.

I run the expo diagnostics:
Expo CLI 3.11.7 environment info:
OS: macOS 10.15.2
Shell: 3.2.57 - /bin/bash
Node: 10.16.0 - /usr/local/bin/node
npm: 6.9.0 - /usr/local/bin/npm
Xcode: 11.2/11B52 - /usr/bin/xcodebuild
expo: ^36.0.1 => 36.0.2
react: 16.9.0 => 16.9.0
react-native: https://github.com/expo/react-native/archive/sdk-36.0.0.tar.gz => 0.61.4
react-navigation: 3.11.1 => 3.11.1
expo-cli: 3.11.7

Previously I have managed to upload the app to Testflight with another account, another app name and another bundleIdentifier. I removed the uploaded app from before tring to upload it for the new account.

Please help me to find a solution.

Best Regards,

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.