expo ui command fails to upload the app to appstore

Please run expo diagnostics and paste the log that’s printed out along with your question or issue!
Expo CLI 3.27.4 environment info:
OS: macOS 10.15.6
Shell: 3.2.57 - /bin/bash
Node: 14.8.0 - /usr/local/bin/node
npm: 6.14.7 - /usr/local/bin/npm
Watchman: 4.9.0 - /usr/local/bin/watchman
Platforms: iOS 13.6, DriverKit 19.0, macOS 10.15, tvOS 13.4, watchOS 6.2
Xcode: 11.6/11E708 - /usr/bin/xcodebuild
expo: ^35.0.1 => 35.0.1
react: 16.8.3 => 16.8.3
react-dom: 16.8.3 => 16.8.3
react-native: https://github.com/expo/react-native/archive/sdk-35.0.0.tar.gz => 0.59.8
react-navigation: ^4.0.10 => 4.0.10
expo-cli: 3.27.4
Expo Workflow: managed

ISSUE: When I run command ‘expo ui’ or expo upload:ios’ to upload the standalone .ipa to testflight , I’m getting an error : Failed to upload the standalone app to the app store.
“owner” is not allowed to be empty, “id” is not allowed to be empty."
Have provided the Apple ID and password correctly, but still getting error.
What is wrong here? do i need to supply additional parameters to the expo ui command?

I was able to updload the app previously, it stopped working now


I’m having the same issue, 2 days ago was working fine

Same here…It was working last night

Same problems here start from today.

1 Like

Same here. It was working previously. Please help.

1 Like

Same here, as of today. When we should expect any resolution?

There’s an alternative and that’s to use an app called “Transporter”.

same here, plz fix this issue

Yeah, something broke. Also having this issue.

Yes please fix this issue i am also facing same issue


We are aware of this issue, thank you for reporting it. From what I see there is PR that is addressing that, so I assume that it will be deployed in a few hours. Fix is server-side, so you won’t need to update expo-cli.

In a meantime, you can use Transporter app as @jacktiong92 already suggested.

1 Like

Also have this issue with “expo upload:ios” gives error “Failed to upload the standalone app to the app store.
“id” is not allowed to be empty.”

The same issue today, works fine before.

Yup, same here :slight_smile: worked fine few days back, still getting this error, 4 hours in the PR … wondering when is this getting back?

This issue should be fixed (server-side fix was just deployed). Let us know if you are still experiencing it. Sorry for the bug and thanks for your patience!

Seems to be working now - thanks!

1 Like

same :frowning_face:

Same here! Can you fix??

Same problems here start from today.

can you share more information? what error are you getting? what’s your build id?

also, lol are you all coworkers? three first posts at the same time :stuck_out_tongue: