Upgrading to SDK 32 - Error `console.error there was a problem sending log messages to your development environment`

I just updated my project to use expo SDK 32 following the instructions in the docs.

I deleted my node_modules, and reinstalled, I also cleared my metro_bundler and watchman caches.

Unfortunately I am running into a bug that I can’t figure out. My project has been working perfectly, and the only thing I’ve done is update from SDK 31 - 32


Here is my package.json

  "name": "frontend",
  "version": "0.1.0",
  "private": true,
  "devDependencies": {
    "jest-expo": "^32.0.0",
    "react-test-renderer": "16.3.1"
  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "expo start",
    "eject": "expo eject",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "test": "jest"
  "jest": {
    "preset": "jest-expo"
  "dependencies": {
    "@expo/vector-icons": "^6.2.0",
    "axios": "^0.18.0",
    "babel-core": "^6.26.3",
    "babel-loader": "^7.1.4",
    "babel-preset-es2015": "^6.24.1",
    "babel-preset-react": "^6.24.1",
    "color": "^2.0.0",
    "expo": "^32.0.0",
    "hoist-non-react-statics": "^2.3.0",
    "moment": "^2.22.2",
    "react": "16.5.0",
    "react-native": "https://github.com/expo/react-native/archive/sdk-32.0.0.tar.gz",
    "react-native-dropdownalert": "^3.1.2",
    "react-native-extended-stylesheet": "^0.8.0",
    "react-navigation": "^2.7.0",
    "react-redux": "^5.0.7",
    "redux": "^4.0.0",
    "redux-axios-middleware": "^4.0.0",
    "redux-logger": "^3.0.6",
    "redux-thunk": "^2.3.0"

And here is my app.json

  "expo": {
    "name": "Hco",
    "sdkVersion": "32.0.0",
    "orientation": "portrait",
    "version": "1.0.17",
    "icon": "./src/assets/images/ios_app_png_border.png",
    "ios": {
      "bundleIdentifier": "com.slmproducts.hco"
    "android": {
      "package": "com.slmproducts.hco"
    "assetBundlePatterns": ["src/assets/images/*"]

Any help would be appreciated as it’s been frustrating.

Some more info -

The message changes if my debugger is enabled to -


I can dismiss the above error and work with my app, but unfortunately it’s annoying to need to dismiss this every time I make a change and save.

This also appears in the console

{AppRegistry.runApplication1: "Running application "main" with appParams: {"rootT…warning are ON, performance optimizations are OFF"}


ExceptionsManager.js:84 There was a problem sending log messages to your development environment TypeError: value.hasOwnProperty is not a function

Same problem here :frowning:


I figured out the problem on my end… I noticed that this was happening anytime I made a call to the backend. It wound up being an issue with axios. The issue I am still not sure of because I was getting there errors even on successful requests.

It was super annoying, but I switched to Frisbee, another promise-based HTTP library and my issue was solved.

If you’re using axios I’d venture to guess it’s the same problem.

1 Like

I’ve come across this issue before and it was when I was trying to log the result of a query I sent using Apollo Client. To fix it, I wrapped the data I was logging in JSON.stringify() and it logged without the error. If you have any console.log it might be worth trying.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.