Updated to Expo SDK v32.0.0 and get "There was a problem sending log messages to your development environment" for every console call made

Hello all,

I am currently trying to upgrade our application to Expo SDK v32.0.0, however running the app in a simulator immediately after loading with expo start -c, I immediately get:

“There was a problem sending log messages to your development environment”, which I am able to dismiss, but will immediately reappear on subsequent calls to console.log, etc. anywhere in the application. I ran expo diagnostics and get the following:

  Expo CLI 2.10.1 environment info:
      OS: macOS 10.14.3
      Shell: 3.2.57 - /bin/bash
      Node: 11.2.0 - /usr/local/bin/node
      npm: 6.7.0 - /usr/local/bin/npm
      Watchman: 4.9.0 - /usr/local/bin/watchman
      Xcode: 10.1/10B61 - /usr/bin/xcodebuild
      expo: ^32.0.0 => 32.0.0 
      react: 16.5.0 => 16.5.0 
      react-native: https://github.com/expo/react-native/archive/sdk-32.0.0.tar.gz => 0.57.1 
      react-navigation: ^2.18.2 => 2.18.3 
      expo-cli: 2.10.1

Thank you for your help!


Some more info for context - this is the console in the JS debugger when the crash happens. Thanks!

Does anyone have any experience with this issue? I’ve seen it referenced a couple of times:

Both without resolution. I can provide additional info if needed, please let me know as I’d like to get this upgrade completed!



I ran into this and reverted back to earlier version. Have not attempted to upgrade since, so I’m interested in finding a solution as well

Update - I was able to find a solution for this issue. It is a bug that appears for me when redux-logger is used in the application. Specifically, if I intercept actions that include a request/response payload, I was able to squash or recreate the error. I was able to squash the error by removing the request property from action.payload in the redux-logger (using lodash/omit):

const logger = createLogger({
    actionTransformer: (action = {}) => {
        if (action && action.payload) {
            action.payload = omit(action.payload, ['request']);
        return action;

Not sure what about the request object is the issue here, but hopefully it will help others (and perhaps the expo team?) resolve this!



Got an issue with ‘Debug js remotely’ enabled in emulator, i fixed it by enabling “cross-origin ressource sharing” when i dev.

might help, might not :hugs:

I got this error consistently when dumping the result of an axios call to console like console.log(result). Once I used console.log(JSON.stringify(result)) the problem went away. I imagine it has something to do with escaping.


This issue for me seems to have ‘resolved itself’

I updated to v32 and things are working, however I did get this error showing up later due to a seemingly unrelated bug in my own code

I’m using graphQL, and was accidentally trying to pass a variable in a query that wasn’t defined in my schema, which oddly enough was throwing this same error.

so maybe this wasn’t related to expo, in my case

Yes, I am also facing the same issue with expo sdk 32.0.0 and axios. Also as gerbus mentioned, with JSON.stringify the error disappears. I think expo cannot handle large data to send on the console. And so I don’t think this has been resolved in expo sdk 32.0.0. Would be great if this gets fixed soon.

1 Like

Had same issue with expo SDK 32.0.0 while using console.log(response) in axios. As mentioned by @gerbus and @kakarn console.log(JSON.stringify(response)) fixed it.


Confirming the same issue, likely on console.log() a larger JSON.
Expo 32.0.0
React-Apollo GraphQL 2.5.1
JSON.Stringify() hepled as well.


I’m also running into this issue. I can’t tell where it is coming from. It appears to be some code in a library that I don’t control using console.log. Highly annoying!

Trying to code in expo has been extremely painful. Is there a fix for this?


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.