Undefined symbol error after Xcode 13 update

I have recently updated my Xcode to v13 . Since then when I tried to archive I am getting following error

Undefined symbol: _OBJC_METACLASS_$_UMAppDelegateWrapper
Undefined symbol: _OBJC_CLASS_$_UMAppDelegateWrapper
Undefined symbol: _OBJC_CLASS_$_UMModuleRegistryProvider
Undefined symbol: _OBJC_CLASS_$_UMModuleRegistryAdapter

If I run in simulator or real device, Then there is no error. Getting errors only when I tired to archiving.

Can someone help me to get rid of these errors?

you should clean your project, run pod install again, and make sure you are building from your xcworkspace file and not xcodeproj

@notbrent
I have done these things a number of times. As I outlined in the issue problem occurs only when I try to archive. Running in simulator or real device no issue.

I found an interesting regarding this issue in this conversation https://www.reddit.com/r/reactnative/comments/pkso5u/undefined_symbols_for_architecture_x86_64/hc68cl6/

get a build of UMModuleRegistryAdapter that has the x86_64 symbols.

I have been searching for solution for past one month. But above one is the only point that seemed a bit related this issue.

Does this point make any sense to you? Can you come to any conclusion from above mentioned point?

if you can share a project where this is reproducible i can help. there isn’t much i can suggest from the error aside from the above and ensuring that you’ve installed the package correctly

@notbrent After lot of struggle for month I resolved this issue just by increasing minimum iOS version form iOS10 to iOS11.

1 Like