Uncaught [Fatal] Error: Expo requires an internet connection

Haven’t fired up the Expo app in a while, but have never run into this issue before now. The android app simply won’t launch. I continually get this error, even after uninstalling and reinstalling. I’m unable to get to the home screen. Clicking the refresh icon causes the app to go to a white screen with the expo logo in the middle, but gets stuck there unless I close and restart the app.

Uncaught Error: Expo requires an internet connection
12:24:57 Fatal Error

2018-10-18_1226

1 Like

Hey @geirman,

How are you serving your bundle? As in what tool are you using.

Cheers,

Adam

I haven’t even gotten that far, meaning I’m not even trying to launch a project. I’m simply trying to get to the Expo home screen so that I can use the QR code scanner to launch a project. At that point, the bundle will be served locally

Ohhh. My mistake. You’re talkin’ about the Expo Client. What version of the Client are you on?

I uninstalled then reinstalled from the play store, so I have the latest v2.8.0

FYI, my app is still on SDK v29, so I’m still using the XDE to run the local server to deliver the bundle. Once I upgrade, looks like I’ll have to start using the CLI. But again, I’m not even getting that far (yet)

We share the same problem @geirman, except mine was working fine, then this started happening

Same, @itsdevinci. It’s been about a month since I’ve tried running the app, but it ran fine last time I tried

It just started yesterday for me, I’ve been scouring the internet, but to no avail… Hopefully @adamjnav has an answer for us

Same problem yesterday night and today.
:frowning:

2 Likes

you can uninstall and reinstall the client to work around it for now, @esamelson is investigating the cause

Unfortunately, I already tried the uninstall/reinstall trick (see above☝️). I tried it again just in case there’d been a recent update in the last couple hours, but I got the same v2.8.0 with the same problem

1 Like

Everyone who’s experiencing this issue – really sorry for the inconvenience :disappointed: we’re trying to track down the cause right now.

If uninstalling/reinstalling the app doesn’t work for you, could you try going into Settings and clearing Expo’s data? It’s possible some phones don’t clear out all of an app’s data when uninstalling it.

3 Likes

Thanks @esamelson! I had considered the need to clear the app data, but couldn’t find the button initially. I looked harder, found the button, and that has resolved the problem for now.

2 Likes

Exactly same issue happened to me. To clear the app data, then it work perfectly again now! Thank you!

Clearing the app data worked for me too. But I wanted to comment that this was an issue for me to let yall know it’s out there.

Any updates on the investigation of this issue? Our customers are experiencing this too.

This issue this thread refers to has been fixed. If your customers are having problems with app loading, could you open a new issue on https://github.com/expo/expo/issues and provide as much detailed information as possible?

If I may ask, when was the fix deployed?

@bdefnet – the fix was deployed midday Pacific Time last Friday, Oct 19. However, the issue here only affected the Expo client app, not standalone apps built with Expo.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.