Unable to update iOS build number via expo build:ios

When I run expo build:ios with a new version & build number (both 1.0.1 in this case, the previous numbers were 1.0.0 and 1 respectively), the changes are not reflected when I upload the binary to App Store Connect. It gives me this error when I run expo upload:ios

ERROR ITMS-90189: “Redundant Binary Upload. You’ve already uploaded a build with build number ‘1’ for version number ‘1.0.0’. Make sure you increment the build string before you upload your app to App Store Connect. Learn more in Xcode Help (http://help.apple.com/xcode/mac/current/#/devba7f53ad4).”

I ran

expo build:ios -t simulator
expo upload:ios

which consistently gives me this error even after updating version and ios.buildNumber in app.json.

Am I doing something wrong or is there a bug?

This is getting pretty urgent.

I have downloaded the most recent build and seen that the Info.plist file inside does contain the correct version number but when I run expo upload:ios it still doesn’t work. It seems that maybe Expo is not uploading the latest build to the Apple store perhaps? I have tried to upload by id with the --id flag but it fails and says

Failed to upload the standalone app to the app store.
An unknown error occurred.

I would like to attempt to upload by using the --path flag but I have no idea how to convert the .app folder into a .ipa. Does anyone know how I could do that?

OK I was able to upload the app by realizing that expo upload:ios uploads the latest build that was NOT built with the -t simulator flag. Now I am concerned that my app will fail review since it needs to be able to run on a simulator. This seems like a catch 22 since an app needs to run on a simulator to pass review but Expo doesn’t upload simulator builds.

What am I doing wrong?

Hi, I’ve always uploaded builds to the apple store review built without the simulator flag and they have never had an issue with it. I think in expo’s case the usage of expo build:ios -t simulator is to make it possible to install the .ipa on the simulator without it being in the app store, it does not mean that builds without that flag are unable to be run on a simulator, just that installation is difficult without the tools such that the actual review have.

In short, when you are building for Apple Store Review/the Store in general, you do not need to use the simulator flag. If you are very worried about it, you could use Application Loader (a dev tool bundled with XCode) to upload the simulator build instead of using the expo cli upload command.


@mickeymcc is correct. You’ll want to just upload a normal build.

1 Like

Thanks for the replies. Everything worked out and the app passed App Store review.

Glad to hear it!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.