Unable to resolve module error: Entypo

I keep getting the following issue every time I try starting up my app. It first happened when I upgraded to Expo 17 so I downgraded back to 16 because that still worked. Now that 18 is out I tried upgrading again thinking this wouldn’t still be an issue but it seems to be. I’m not even using Entypo at all in my project which makes this all the more strange:

9:33:31 PM
Building JavaScript bundle: error
Unable to resolve module `@expo/vector-icons/glyphmaps/Entypo.json` from `C:\Users\Brady\Documents\Exponent\screen-wars\node_modules\@expo\vector-icons\Entypo.js`: Module does not exist in the module map or in these directories:

This might be related to https://github.com/facebook/react-native/issues/4968
To resolve try the following:
  1. Clear watchman watches: `watchman watch-del-all`.
  2. Delete the `node_modules` folder: `rm -rf node_modules && npm install`.
  3. Reset packager cache: `rm -fr $TMPDIR/react-*` or `npm start -- --reset-cache`.
9:33:49 PM
Dependency graph loaded.
9:33:51 PM
Your JavaScript transform cache is empty, rebuilding (this may take a minute).

hello! could you show me the contents of your .babelrc and package.json? alternatively you could share your entire project with me: brentvatne on github

I actually seemed to get it working. Turns out I was using an outdated version of @expo/vector-icons.

1 Like