Unable to resolve module 'module://expo-font.js'

It says evaluating react-native-elements.js. I haven’t changed any of my code since last night, where it was working on my phone. This only happens when running on a mobile device (happens in the appitize emulator and expo client app).

Help? I’m NOT importing expo-font anywhere.

My package.json:

  "dependencies": {
    "axios": "0.19.2",
    "react-native-paper": "3.1.1",
    "react-native-elements": "1.2.7",
    "react-native-vector-icons": ">= 6.x.x",
    "@freakycoder/react-native-helpers": ">= 0.1.0",
    "react-native-dynamic-vector-icons": ">= x.x.x"
1 Like

I’m seeing errors for multiple kinds of modules now. Even when I create new projects (and try to run the default project see https://snack.expo.io/@avatarofwoo/quiet-cake for an example). I don’t have any solution for it yet but I believe it’s on their side since our code used to work.

I also found an example online where it works on mobile but bugs out with a “can’t find a module” error on the web preview. https://snack.expo.io/@avatarofwoo/51738e

Edit: added the project link

Edit2: found an example that’s the opposite

I can confirm I was getting similar errors earlier for expo-constants on my Android phone, but it was working without complaint in the Web preview.

1 Like

@surprisejedi and @avatarofwoo

Try now? It seems to have been fixed.

@avatarofwoo/51738e fails locally too with the following error, so I don’t think that’s a problem with Snack:

 web  Failed to compile.
Module not found: Can't resolve './datepicker' in '/tmp/react-native-login-form/node_modules/tcomb-form-native/lib/templates/bootstrap'
1 Like

Yeah I just tried and I’m getting an error still with my main projects. The other projects do work now.

My issue is

Unable to resolve module ‘module://react-native-screens.js’
Evaluating module://react-native-screens.js
Evaluating module://react-navigation-stack.js
Evaluating module://App.js.js
Loading module://App.js

Like the OP, things were working for me until recently. I even went back 25 days and got the same error.

1 Like

I tried running expo init -t tabs and imported the result into a snack. I got weird errors with expo-font until I removed the react-native-paper dependency from package.json.

After that I was getting a 403 Forbidden error related to react-native-screens. So it seems that although the initial problem from yesterday is fixed there’s still something funny going on.

1 Like

Helpful info. I was also seeing 403 errors for react-native-screens when trying to include it in my package.json a couple days ago. Less sure it’s snack/expo’s fault now but I’m curious why so few people are reporting the issue

1 Like

Still not working!!! Can any devs acknowledge this?

1 Like

I’m getting the same 'Unable to resolve module ‘module://react-native-screens.js’ error.
Code works fine locally but when I run the code in a snack, that’s when I get the error.

1 Like

Hi all,
We’re in the process of rolling out some changes to snack that allow the web simulator to load significantly faster but are turning up some underlying bugs in the process.
403’s when loading react-native-screens should now be resolved and we’ll continue working through the rest of these reports :pray:
Sorry for the interruption! If we haven’t gotten to an issue that is blocking you yet, dropping down to SDK 35 should continue to function the same as before these changes.

1 Like

Thank you so much but i’m getting a new error:
Unable to resolve module ‘module://react-native/Libraries/Core/ReactNativeVersion.js’
Evaluating module://react-native/Libraries/Core/ReactNativeVersion.js
Evaluating module://react-native-screens.js
Evaluating module://react-navigation-stack.js
Evaluating module://App.js.js
Loading module://App.js

my package.json:
“dependencies”: {
“moment”: “2.24.0”,
“react-navigation”: “^4.0.10”,
“react-native-modal”: “^11.1.0”,
“react-native-elements”: “1.2.7”,
“react-navigation-tabs”: “^2.5.6”,
“react-navigation-stack”: “^1.10.3”,
“react-navigation-drawer”: “^2.3.3”,
“react-native-vector-icons”: “^6.6.0”,
“react-native-multiple-select”: “^0.2.5”,
“react-native-vector-icons/FontAwesome”: “6.6.0”,
“react-native-screens”: “2.0.0-alpha.12”

Edit: no rush to help me fix this since I can just drop down the version :slight_smile:

1 Like

I still have the “Unable to resolve module ‘module://react-native-screens.js’” at SDK 36 when I import from @react-navigation/bottom-tabs

Dropping down to SDK 35 creates a new seemingly unrelated error -:

Unable to resolve module ‘module://react-dom.js’
Evaluating module://react-dom.js
Evaluating module://react-redux.js
Evaluating module://App.js.js
Loading module://App.js

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.