Troubles in building singed apk again

Hi, Everybody.
I have a trouble to build signed apk again for upgrading version from 1.0 to 1.1.

Followings are what i did.

  1. First i built an apk by choosing 1) Let Expo handle the process!.
  2. And then uploaded the apk to google store.
  3. Nowdays, i have to upgrade the version, but i don’t have any keystore file.

These are what i tried to do.

  1. Downloaded upload_cert.der file from Google store.
  2. Created a keystore file by this command
    keytool.exe -importcert -file upload_cert.der -keystore <keystorefile>.keystore
  3. Built an apk by choosing 2) I want to upload my own keystore!
  4. But can’t install the apk with an error.
    When i run this command keytool -printcert -jarfile <apkname>.apk,
    this message appears Not a signed jar file

So Could you everybody let me know please…

  1. Is this really impossible to upgrade apk without original keystore
  2. Or how to create a correct keystore from upload_cert.der file


Hi @an_react, you need the original keystore to submit an update. You can download the keystore that Expo generated using exp fetch:android:keystore.

Hi, @jesse. Thanks for your message,
Unfortunately, but already I made the mistake of doing this - expo build:android --clear-credentials

Is there any way?

Are they still in iTunes ?

--clear-credentials is permanent. It does copy the keystore into a .jks.bak file in your project directory, so you should check to see if that’s still there. We don’t have any way to recover credentials that have been cleared since the keystores are sensitive and we want to respect when people ask us to remove them.

Ok, thanks for your kind answer.
no ways, let me upload it as a new app.
thanks again.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.