Text Become Grey on Bare Workflow

I. Problem

Recently I am developing an app using Expo Bare Workfow. I tried to use custom font called Campton to my project. When I run yarn ios , everything works fine on iOS, the font appears black as its default color. However, when I start using yarn android , everything still works fine except the font appear grey instead of black as its default color. I have tried to change to another color (e.g. #C30017) but still the color remain grey on Android.

I tried to use react-native-cli to generate fresh new project instead of using expo-cli, everything works fine and I am able to change the font color through styles.xml for Android.

II. My Approach to Solve

  1. Add custom font to the project => run npx react-native-link

  2. Edit the android:textColor at my_project/android/app/src/main/values/styles.xml

  3. Found the answer on forum / community

  4. Find the source code regarding the grey color on expo

III. Result

IV. Expected Result

The default font color is black, and I am able to change the font color through android:textColor at my_project/android/app/src/main/values/styles.xml

V. Environment

Expo CLI 4.3.2 environment info:
OS: macOS 11.2.3
Shell: 3.2.57 - /bin/bash
Node: 14.15.0 - /usr/local/bin/node
Yarn: 1.22.10 - /usr/local/bin/yarn
npm: 6.14.11 - /usr/local/bin/npm
CocoaPods: 1.10.1 - /Users/jaico/.rvm/gems/ruby-2.6.5/bin/pod
Platforms: iOS 14.4, DriverKit 20.2, macOS 11.1, tvOS 14.3, watchOS 7.2
Android SDK:
API Levels: 23, 24, 25, 27, 28, 29
Build Tools: 29.0.0, 29.0.1, 29.0.2, 29.0.3, 30.0.0, 30.0.1, 30.0.2, 30.0.3, 31.0.0
System Images: android-27 Google Play Intel x86 Atom, android-29 Google APIs Intel x86 Atom
Android Studio: 4.1 AI-201.8743.12.41.7042882
Xcode: 12.4/12D4e - /usr/bin/xcodebuild
react: 16.13.1 => 16.13.1
react-native: 0.63.4 => 0.63.4
expo-cli: 4.3.2
Expo Workflow: bare

hi there! can you share a copy of a project that reproduces this problem, on github?

Euuumm unfortunately I can’t share the project, since I don’t have permission to share the project. I am sorry for that, Sir. However, I’ve tried to create a freshly new project using Expo Bare Workflow, here below is the detailed steps:

  1. run npm install -g expo-cli
  2. expo init
  3. select the bare minimal project
  4. run yarn start
  5. run yarn android

when it successfully build the app, it works pretty well. However, the default font color is not black instead it appears grey as shown in my screenshot above. I tried to change the default font color by modifying android:textColor at my_project/android/app/src/main/values/styles.xml, re-build the project, and the font still appear grey. The same thing happens between my project and my freshly new expo bare workflow project.

However, when I tried uisng react-native-cli, instead of expo-cli to create freshly new app, both android and ios renders font with black as its default font color. Here below the detailed steps when creating freshly new app using react-native-cli:

  1. npm install -g react-native-cli
  2. react-native init myProject && cd myProject
  3. yarn start
  4. yarn android && yarn ios

I apologize, I still do not understand why, I think when creating project using expo bare workflow, I have more privilege to edit the native code, but when I tried to edit the styles.xml file on Android, it does not change anything.

Any help? Please…