(Solved) [Android] Google app auth issue

I built my app from scratch as a bare app after using expokit for a couple years and I have this one issue left to fix before production. After login in with google app auth (browser) on android I get offered two instances of my app to redirect. One works and the other doesn’t. In both instances I’m returned to my app, but one of them doesn’t complete the login. The login button then becomes unresponsive, and I get the following messages:

[Error: Cannot start a new task while another task is currently in progress: Get Auth]
[Error: ExpoAppAuth.Get Auth: Cannot start a new task while another task is currently in progress]

I wonder why I have this new pop up, since this wasn’t the case with my expokit app.

I hope someone can help me.
Thanks in advance.

Edit: It seems like the problem was a configuration parameter on my build.gradle file. My manifest placeholder for appAuthRedirectScheme was pointing to the same scheme I had defined on my AndroidManifest. The placeholder was auto generating an intent-filter that collided with my .mainActivity’s intent-filter. I changed the placeholder to something else (‘host.exp.exponent’) and now it works. I tried removing the placeholder from my gradle file, but it seems it’s needed for something else (firebase, maybe), even though I haven’t found any error in my testing.