SDK 48 Expo Doctor ~ @config-plugins and @prebuilld-config invalid versions

Hey, i just upgraded to SDK 48 (development builds) following this guide , and when im running npx expo-doctor im running into the issues above which also fails at build with “eas build”,
i think i tried already everything npx prebuild --clean, npx expo doctor --fix-dependencies, removing node modules, removing the android folder and more… npx expo install --fix states that everything is up to date, the local build with “npx expo run:android” do work but nothing else, help would be much appreciated, thanks in advance!

Hi. I ran into a similar problem. Discovered that it’s possible to override the errors by updating your package.json file. I’m running npm so added the following section (I was also getting warning about expo-modules-autolinking). Yarn section is different. You should be able to Google yarn update by searching for expo doctor and config-plugins and prebuild-config.

“overrides”: {
@expo/config-plugins”: “^6.0.0”,
@expo/prebuild-config”: “^6.0.0”,
“expo-modules-autolinking”: “~1.1.0”

Also, if you get the ‘sh’ is not recognized error. You have to run npx expo-doctor in bash shell that recogizes shell scripts. I’m using Visual Studio Code. If you have git installed, you can switch the terminal to use git bash. With that as your terminal os, it will be able to run all of the checks used by expo doctor.

Hi @olegwork330

The error about “sh” looks like a bug in expo-doctor. It seems to be trying to run a Unix shell, but you’re running Windows. Also, it’s warning you to use PowerShell, but you seem to be using PowerShell already, so that’s strange.

To track down where the @expo/config-plugins issues are coming from, run this:

npm why "@expo/config-plugins@5.0.1"


npm why "@expo/config-plugins@5.0.3"

I suspect you have some config plugins installed that were written when Expo SDK 47 was current and maybe you can update them.

Hi @bjs0008

I think “overrides” is the npm equivalent of yarn’s “resolutions”. While that might get expo-doctor to stop complaining, it would be better to fix the underlying problem if at all possible.

I think you’re right that git bash would probably workaround the sh issue, but I still believe it’s a bug in expo-doctor.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.