Remote debugging causes error: Unable to execute JS call: __fbBatchedBridge is undefined

I’m currently running Expo ^18.0.4 and RN ^18.0.1.
Whenever I activate JS Remote Debugging, I get the error:

Unable to execute JS call: __fbBatchedBridge is undefined

After this Expo won’t start anymore. It shows me the error:

Error running xcrun simctl openurl booted exp://localhost:19000: An error was encountered processing the command (domain=NSPOSIXErrorDomain, code=60):
The operation couldn’t be completed. Operation timed out
Operation timed out

The only way to get my app & Expo working again is to reset the Simulator Content & Settings (and thus deactivate remote debugging).

Changing Host or Protocol does not seem to fix the problem.
I also already tried a couple of solutions on the web, including modifying the react native file ( None of them have worked for me so far.

Do you have any suggestions to bug fix?

Yes same here. I encounter this when I open Remote JS Debugging. In order to fix this error, I have to reset content of my ios simulator and re-run the expo client again. But I am not able to do Remote JS Debugging anymore as it will definitely lead to the same error.

Expo version: 19.0.0

Hi! Thanks for the report and sorry for the annoyance. We’re tracking this issue here and don’t have a solution yet. (but we’re working on it.)