Help: expo/npm start


When i am hitting expo start/npm start command to run the react-native app. I’m getting this error on mac:-

Could not get status from Metro bundler. connect ECONNREFUSED
Connecting to Metro bundler failed.
Set EXPO_DEBUG=true in your env to view the stack trace.

Can anyone please let me know why i am getting this error.



This is actually listed in our Common Development Errors.

  • An error is preventing the connection to your local development server.
  • Run rm -rf .expo to clear your local state. Check for firewalls or proxies affecting the network you are currently connected to.

Let me know if that works!

Hi @charliecruzan,

I have run rm -rf .expo
and then run npm install

Error running xcrun simctl openurl booted exp:// An error was encountered processing the command (domain=NSPOSIXErrorDomain, code=60): The operation couldn’t be completed. Operation timed out Operation timed out

Error installing or running app. Error: xcrun exited with non-zero code: 60


This could be an issue with Apple’s tooling and is typically fixed by hitting “Reset Content and Settings” on your simulator. I’ve also seen this happen when an Xcode update didn’t completely finish, so I’d try to open up Xcode as well :+1:

Hi @charliecruzan,

I have tried Reset Content and Settings on simulator and for the first time its working fine
and then again i have the same error.
I am getting this error when i connecting on local and run on ios on simulator on http://localhost:19002/


Could you run expo diagnostics and paste the output here?

Here is the output:-

Expo CLI 2.18.2 environment info:
OS: macOS High Sierra 10.13.6
Shell: 3.2.57 - /bin/bash
Node: 10.15.3 - /usr/local/bin/node
npm: 6.4.1 - /usr/local/bin/npm
Watchman: 4.9.0 - /usr/local/bin/watchman
Android Studio: 2.2 AI-145.3537739
Xcode: 10.1/10B61 - /usr/bin/xcodebuild
expo: ^31.0.0 => 31.0.6
react: 16.5.0 => 16.5.0
react-native: => 0.57.1
react-navigation: ^3.0.9 => 3.9.1
expo-cli: 2.18.2


Not sure what’s causing the simulator to get into a bad state, since Reset Content and Settings is working (at least for a little while).

Can you try a brand new expo init project and see if you get the same behavior?

Also- if you can, please share more of your logs. This way I can better dig into issue :+1:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.