Error with remote debugger after updating to SDK 25

I’m getting the following error message in the remote debugger console when starting up my Expo app on Samsung S6 device over wifi:


This post-SDK25 update error was also brought up by another user in create-react-native-app/#392 (comment). Any thoughts would be appreciated!

1 Like

Hey @flyylikeaduck - try serving your project using LAN or localhost. (If you’re using exp, you can do exp start --lan/--localhost.) That should fix it, but let us know if not!

I had the same problem. I decided to downgrade back to 24 sdk to make it work again. changing to local ip address does not work. I think there are a quite few people with this problem.

1 Like

Yeah, i can’t use the remote debugger on SDK 25 and it gave the same error, i tried creating a new project but it’s still the same. @esamelson i switch to LAN & localhost but still the same error

1 Like

Hey all, sounds like this is an upstream issue in react-native - see here for more details . Looks like a fix will be out in the next Expo SDK release. In the meantime, you might be able to try this workaround if you need to use debugging in SDK 25. Sorry for the inconvenience!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.