Push notification error DeviceNotRegistered


I open this new topic because I realize there is a lot of feedbacks about this issue and nothing is found to solve it. Furthermore it is a really big issue and I guess a lot of projects are impacted.

Context :

  • I am on a standalone app
  • I identified the issue with two iPhones but I have not Android device under the hand. Anyway I think the problem is not especially on iOS.
  • Until now the both devices received push notifications correctly but suddenly I realized that I did’nt received notifications for no apparent reason
  • I tried to send a notification to the both expoPushToken concerned (with Push Notification Tool — Expo) and got the next message :
    "'The recipient "ExponentPushToken[E9qkS3CVSyp6fpdiodmTN0]" is not associated with a device actively registered to receive push notifications; stop sending notifications to this recipient until you get an Expo push token from it once again and still have its permission to send notifications."
  • Of course notification permission is turned to “on” on the both devices.
  • After that I realized there are a lot of users in my database that have the same error
  • I don’t know if the issue is temporary (that is to say a KO expoPushToken can turn OK later. I will see this in the next days.

The only workaround I found is to delete the app from iOS and reinstall it. This way a new expoPushToken is delivered and everything becomes ok again. I can do it but I obviously cannot ask my users to do it…

Given this, I really would like we find together a solution.

Is there a way to give another expoPushToken to a device when the device is no more registered ?
Is there a way to get an reason why the device is no more registered ?

1 Like

same issue here.

same issue :frowning:

Same issue :disappointed:

Has somebody tried the other notifications tools as oneSignal ? Is there the same issue ? Is it mandatory to detach from expo to use it ?

Same here.

1 Like

Same issue.

Here’s the discussion of this problem on Github: https://github.com/expo/expo/issues/1745

1 Like

I wouldn’t use OneSignal if you value your users’ privacy…

Same issue

Hi everyone! Normally this message occurs when Apple/Google have specifically told us to deregister the device in question. However, I’d like to rule out some recent changes to our service that may be causing this erroneously. If you’re still experiencing this problem, could you please email me any Expo push tokens that are still affected?

Ok I will send you some affected token ASAP ! Thanks for your help.

Hi everyone! Sorry this took a little while to discover, the underlying bug here was caused by a caching error being swallowed and converted into a “token no longer valid” error. We’ve resolved the caching issue and will be following up soon to prevent this from happening again. This problem does not appear to have affected the majority of users, but we’re extremely sorry for everyone who was affected.

If you’re still seeing this error, please let us know and we’ll look into it!

1 Like

Good news. I will test it ASAP !

Hey I just tested it and it works again with one affected token. :+1:t3::pray:t4::tada:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.