Published Expo application crashed on Launch. "AppRegistry is not a registered or callable module"

I understand that the “AppRegistry is not a registered callable module” error means that there was an issue that stopped the application from starting. This is an error that’s only happening in production on my application. I’ve tried running the application through the exp cli by issuing the exp start --lan --no-dev --minify flags to simulate a production environment, but the application will load fine when loading from LAN.

When I load it from Expo directly, there’s an issue. The problem here is that there’s no logs to help, and even when using exp it’s working fine through LAN (on simulator and device) so I can’t debug the reason that the application will not start.

The only information I can get is from the “Problem loading this experience” screen which results in Error Code: CLIENT_LOADING_ERROR STATUS_CODE: 2

Loading from my private address on expo fires the app up just fine, but loading from the published expo version (Same exact package) results in a crash during launch. I’ve gone through every little thing I can think of, but with the app running just fine on one end with no issues, and not even starting on the other (WITH THE SAME PACKAGE) I’m left with a confusing issue to solve.

Yes, I’ve also tried just unchecking “Development mode” inside of XDE. Everything loads fine there too.

Here’s my app.json

  "expo": {
    "privacy": "unlisted",
    "sdkVersion": "25.0.0",
    "name": "Removed - For Privacy",
    "slug": "removed-for-privacy",
    "description": "This project is really great.",
    "version": "1.0.0",
    "orientation": "portrait",
    "scheme": "removed",
    "splash": {
      "image": "./assets/splash.png",
      "resizeMode": "contain",
      "backgroundColor": "#ffffff"
    "ios": {
      "supportsTablet": true,
      "bundleIdentifier": "removed.for.privacy",
      "buildNumber": "10",
      "icon": "./assets/icon-ios.png",
      "config": {
        "usesNonExemptEncryption": false,
        "branch": {
          "apiKey": "key_live_*****"
    "android": {
      "icon": "./assets/icon-android.png",
      "package": "removed.for.privacy",
      "config": {
        "branch": {
          "apiKey": "key_live_*****"
    "androidStatusBar": {
      "backgroundColor": "#808080"
    "assetBundlePatterns": ["assets/images/*", "assets/fonts/*", "assets/videos/*", "assets/sounds/*"]

Using the tunnel works as well and other users can load the app just fine.

Hey @christiantucker - sorry this is so frustrating :frowning: Unfortunately, as you probably suspect, the “AppRegistry is not a registered callable module” error doesn’t really tell us anything about what’s really going on. Could you check your device logs to see if there’s another error happening before the “AppRegistry” error?

Also, just to double check, have you run exp publish recently? I’m assuming that’s what you mean by “same exact package” but just want to be sure.

If none of the above work, you can send over a link to your published app and we’ll try and help debug it.

I have an iPhone and a Windows computer so I’m not really sure how to get the logs for you, but to make things even more strange the issue went away at complete random. (Without me publishing a new package). I use XDE to publish and not the command line.

Here’s the link to the application (Totally ruins me having everything blocked out in the app.json earlier, but we’re going live soon anyway): Expo (Warning to people who download the app, content is user generated and you may run into NSFW material. We try to moderate and keep everything clean, but it’s always a possibility)

Since this problem was “Self-Resolving” it worries me, becasue what if it “Self-Unresolves” while we’re on the app store.

I went ahead and laid down to wait for a reply on the forum when all of a sudden I get a text from one of my team members saying “The TestFlight and Expo are working now, Good Job.” Which really confused me, as I haven’t done anything to fix the issue. I haven’t even been able to debug it. @esamelson

Hey @christiantucker - glad it’s “fixed,” though sorry that it’s not a super satisfying resolution :confused: I understand your hesitation about it possibly “un-resolving”, but unfortunately we can’t do anything to help you diagnose the error without more information. (FWIW, I tried opening the app a couple times and it opened just fine for me every time.) The best thing I can suggest is to try and use someone else’s mac to retrieve the logs from your iPhone the next time it happens (if it ever does).

Sorry to not be of more help!!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.