Problem Building Android App with custom Keystore


I’ve run into some problems publishing my App to the PlayStore. The scenario is the following:

I have successfully built and uploaded an App Bundle to the Play Console with Expo Account A. Everything worked fine and the app is available on the store.
Now I want to switch Expo accounts, because I wanna move from my private to a business account.

Now for building the App with the new Expo Account B.
1.) I signed into my Expo Account A, which already has the App in the store.
2.) I fetched the Keystore using expo fetch:android:keystore and saved it as well as the passwords
3.) Using keytool and the App Signing Tab in the PlayConsole I confirmed this is the right Keystore.
4.) I swicthed to Expo Account B
5.) I ran the command expo build:android -c -t app-bundle --release-channel release
6.) I chose to use my own Keystore (option 2)
7.) Entered the path to the file as well as the passwords (keystore password for keystore, and key password when asked for it).
8.) Everything runs thru fine and i get the .aab file
9.) Using keytool or uploading to the Play Console it shows, that the fingerprint does not match with the keystore I originally used.

I am not quite sure where I went wrong.

Any help would be appreciated :slight_smile: If you need any more information, please let me know.

Can you ran expo fetch:android:keystore on the new account and verify with keytool if the fingerprint is the same?

What version of expo-cli are you using?

Does the keystore fingerprint matches app singing certificate or upload certificate on Play console?

1 Like


yes, the keystore fingerprint from the new account and the app bundle fingerprint are the same.
The old account’s keystore fingerprint matches the upload certificate fingerprint.

The CLI version I was using was expo-cli 3.18.2. Updating the CLI actually fixed the problem, now I can succesfully change the keystore used and upload it to the Play Console.
Thank you, I didn’t even think of that.

1 Like

Happy to hear you got things unblocked, @timleuschner. Thanks for the assist, wkozyra.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.