New update available, downloading...

It seems that the details above don’t provide a permanent fix. The key seems to be in changing the resolution.

Using ‘Open in pop-up view’, letting it load in, and then changing back to full-screen view solved the issue each time.

When I run into this issue, I fix it by deleting the node_modules folder and running npm install again. Fixed it everytime so far.

Thank you! This seems to work for us as well (currently opening up in split-screen as a workaround), I wonder what could be causing this? It seemed to work fine before the expo go update.

Same issue !!

Expo CLI 4.4.3 environment info:
System:
OS: macOS 11.2.3
Shell: 3.2.57 - /bin/bash
Binaries:
Node: 14.16.0 - /usr/local/bin/node
npm: 6.14.11 - /usr/local/bin/npm
Watchman: 4.9.0 - /usr/local/bin/watchman
SDKs:
iOS SDK:
Platforms: iOS 14.4, DriverKit 20.2, macOS 11.1, tvOS 14.3, watchOS 7.2
IDEs:
Xcode: 12.4/12D4e - /usr/bin/xcodebuild
npmPackages:
expo: ~41.0.1 => 41.0.1
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: https://github.com/expo/react-native/archive/sdk-41.0.0.tar.gz => 0.63.2
react-native-web: ~0.13.12 => 0.13.18
npmGlobalPackages:
expo-cli: 4.4.3
Expo Workflow: managed

Please Help !!

1 Like

https://youtu.be/8zh164zwwro?t=22 Try this video, it had helped me. You guys could try for this same problem

Had a similar problem when working in the app.json and app.config.js files.

No matter what I did there was an error.

Removed the expo app from the device, and reinstalled expo.

Stopped the expo server, restarted it.

Turned out there was a configuration issue which finally showed up (was looking for app.json when I had renamed it, and named it back). Server got confused even when re running it with cache clear (expo start -c).

REMOVED expo from phone, then reinstalled from play store, New update available, downloading went away and it ran perfectly. I’ve seen this before, sometimes you just need to remove expo from the phone and reinstall it.

Same same error here!
Mac OS Darwin
Expo-cli: 4.8.1
Android Emulator

Any updates on this? Looks like a lot of people are experiencing the same problem.

This happedned to me when upgrading from SDK42 to SDK43, the problem is below.

The solution was to delete the node_modules folder and yarn.lock file and run yarn again

Start afresh and also it is better to log in to you expo account in Expo Go on your device

jest-haste-map: Haste module naming collision: rxjs/ajax
  The following files share their name; please adjust your hasteImpl:
    * <rootDir>\_node_modules\rxjs\ajax\package.json
    * <rootDir>\_node_modules\rxjs\src\ajax\package.json

Failed to construct transformer:  DuplicateError: Duplicated files or mocks. Please check the console for more info
    at setModule (C:\dev\roject\node_modules\jest-haste-map\build\index.js:543:17)
    at workerReply (C:\dev\project\node_modules\jest-haste-map\build\index.js:614:9)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async Promise.all (index 36172)
    at C:\dev\project\node_modules\jest-haste-map\build\index.js:426:22 {
  mockPath1: '_node_modules\\rxjs\\ajax\\package.json',
  mockPath2: '_node_modules\\rxjs\\src\\ajax\\package.json'
}
Error: Duplicated files or mocks. Please check the console for more info
    at setModule (C:\dev\project\node_modules\jest-haste-map\build\index.js:543:17)
    at workerReply (C:\dev\project\node_modules\jest-haste-map\build\index.js:614:9)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async Promise.all (index 36172)
    at C:\dev\project\node_modules\jest-haste-map\build\index.js:426:22
Error: Duplicated files or mocks. Please check the console for more info
    at setModule (C:\dev\project\node_modules\jest-haste-map\build\index.js:543:17)
    at workerReply (C:\dev\project\node_modules\jest-haste-map\build\index.js:614:9)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async Promise.all (index 36172)
    at C:\dev\project\node_modules\jest-haste-map\build\index.js:426:22
Error: Duplicated files or mocks. Please check the console for more info
    at setModule (C:\dev\project\node_modules\jest-haste-map\build\index.js:543:17)
    at workerReply (C:\dev\project\node_modules\jest-haste-map\build\index.js:614:9)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async Promise.all (index 36172)
    at C:\dev\project\node_modules\jest-haste-map\build\index.js:426:22
› Stopped server
Done in 193.77s.

Quando aparecer a mensagem: “New update available, downloading…” fecha o Expo e muda no browser a conexão de LAN para Tunnel. Abre o Expo novamente no celular e vai em Recently opened que provavelmente vai funcionar.

I have similar problem. When running on hardware devices my app works as intended however when i publish to a release channel it is stuck on the splash screen with “new update available, downloading”. I have attempted the solution “expo upgrade, delete node_modules folder and yarn.lock file, run yarn” which did not fix the issue.

I fixed it finally by rearranging pages in the navigation Container. I don’t know why this fixed the problem but it did. Maybe this will work for someone else.

How were you’re pages arranged before and how did you re-arrange them ??
I have the same issue

there was no discernable pattern to it. I just had a hunch because i removed the page and suddenly it started working again. so i swapped that page with the one above it and it worked again.

The team and I were having this problem too when trying to load the published app on Expo Go (both Android and iOS). We tried everything - reinstalling the app, clearing caches, logout/login, restart phone but nothing works. This problem started happening to us when we upgraded to the latest Expo SDK43.

We finally managed to fix it by resolving a library dependency issue with @react-native-picker/picker. Our application had v2 of @react-native-picker/picker, and v2 of native-base installed.

We tried to upgrade the version of native-base but still had an error when trying to run Expo locally.

Error on Android:
image

Error on iOS:
Sorry, I am not able to upload image as I am still a new user to this forum.
But the error message is similar to Android:
“Uncaught Error: Tried to register two views with the same name RNCPicker”

All the problems went away after we uninstalled @react-native-picker/picker library and use the Picker component from native-base. We could run the app perfectly fine locally, as well as on Expo Go