Link external lib to detach expo project in xcode 10

I’m trying to link the lib in my detach expo in xcode 10. What I tried:

  1. Follow README : the error undefined is not an object (evaluating '_reactNative.NativeModules.RNTextInputMask.mask')

  2. Linking as external lib : the error 'React/RCTBridge.h' file not found

  3. Creating my own podfile: :-1: Value for SWIFT_VERSION cannot be empty. (in target 'InputMask')

Since I know the lib has been requested as part of expo framework. Maybe someone can help with it.

on Github

expo diagnostics
OS: macOS 10.14
Node: 9.8.0
Yarn: 1.5.1
npm: 5.6.0
Watchman: 4.9.0
Xcode: Xcode 10.1 Build version 10B61
Android Studio: 3.0 AI-171.4443003

Packages: (wanted => installed)
expo: ^30.0.1 => 30.0.1
react: 16.3.1 => 16.3.1
react-native: => 0.55.4

Hey @fausto,

Have you looked into configuring the Header Search Paths mentioned here?



@adamjnav it’s requiring class found at React which already imported on xcode via PODS_ROOT. Tried to add

  • Header Search Paths "/Users/xyz/Projects/coding/myapp/node_modules/react-native-text-input-mask/ios"
  • Header Search Paths "/Users/xyz/Projects/coding/myapp/node_modules/react-native-text-input-mask/ios/**"

Nothing works. Man, just stuck in this stuff for weeks… Does anyone have an ideia I can try?

Just found a solution which is described here react-native-community/react-native-text-input-mask#73 (comment)

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.