Javascript Bundle iOS Stuck

Hi there, im having this issue after the QR Scan.

Building javascript bundle 99% and restart automatically from 0 to 99%, I let it build several times but nothing happens just keep doing.

Android works fine.

Any advices?


Hey @seba07 I’m sorry you’re having this issue, could you tell us more about the project you’re trying to open? Which SDK version? Are you able to start a new project without issues?

Hey jimmy, im using the latest sdk (24.0), didnt tried to start a new project from scratch but I tried others hellos worlds repo and didnt have the same issue. If you need to see our app.json let me know.


Have you tried reinstalling your dependencies with a rm -rf node_modules and fresh install? What is your NPM version and Node version?

Yeah, did that, even with two differents laptops one with ubuntu and the other one with macOS both with the same result.
NPM Version: 4.6.1
Node Version : 8.6.0

Hey there - not sure why you’re seeing this issue. Could you post your app.json and package.json files, or even better, link to your app so we can try and reproduce this?

It’s possible that if you have other third party dependencies installed in your package.json that they might be causing this, so another thing you could try is removing dependencies & seeing if your package completes.

Sorry for the inconvenience!

1 Like

Hey there, sure, can you sendme your github user so i can give you access to the repo?.
Let me know if that is enough.

Hello again, this is the app.json:

“expo”: {
“scheme”: “cheztoi”,
“name”: “cheztoi”,
“slug”: “cheztoi”,
“icon”: “./assets/react.png”,
“version”: “0.0.1”,
“sdkVersion”: “24.0.0”,
“primaryColor”: “#83DAC4”,
“loading”: {
“icon”: “./assets/react.png”,
“hideExponentText”: false,
“backgroundColor”: “#83DAC4
“androidStatusBar”: {
“barStyle”: “light-content”,
“backgroundColor”: “#83DAC4”,
“android”: {
“package”: “com.cheztoi”,
“ios”: {
“bundleIdentifier”: “com.cheztoi”
“notification”: {
“assetBundlePatterns”: [

This is de package.json

“name”: “cheztoi-mobile”,
“version”: “0.0.1”,
“description”: “Cheztoi react native app”,
“private”: true,
“main”: “./node_modules/react-native-scripts/build/bin/crna-entry.js”,
“scripts”: {
“start”: “react-native-scripts start”,
“eject”: “react-native-scripts eject”,
“android”: “react-native-scripts android”,
“ios”: “react-native-scripts ios”,
“test”: “node node_modules/jest/bin/jest.js --watch”
“repository”: {
“type”: “git”,
“url”: “git+”
“dependencies”: {
“expo”: “^24.0.0”,
“jwt-decode”: “^2.2.0”,
“lodash”: “^4.17.4”,
“native-base”: “^2.3.5”,
“query-string”: “^5.0.0”,
“react”: “16.0.0”,
“react-native”: “”,
“react-native-auth0”: “^1.2.0”,
“react-native-calendars”: “^1.14.2”,
“react-native-easy-grid”: “^0.1.15”,
“react-native-hr”: “^1.1.3”,
“react-native-infinite-scroll-view”: “^0.4.3”,
“react-native-looped-carousel”: “^0.1.7”,
“react-native-star-rating”: “^1.0.8”,
“react-navigation”: “^1.0.0-beta.21”,
“react-redux”: “5.0.5”,
“redux”: “3.7.2”,
“redux-form”: “^7.2.0”,
“redux-logger”: “3.0.6”,
“redux-thunk”: “^2.2.0”
“devDependencies”: {
“babel-jest”: “20.0.3”,
“babel-preset-expo”: “2.0.0”,
“jest”: “20.0.4”,
“jest-expo”: “^24.0.0”,
“react-native-scripts”: “1.0.0”,
“react-test-renderer”: “16.0.0-alpha.12”,
“remote-redux-devtools”: “^0.5.12”
“jest”: {
“preset”: “jest-expo”

Here is the link:

Let me know.

Some suggestions from a guy who makes lots of silly mistakes:

  • Are you running over LAN? Try to restart the server with better internet connection and make sure you don’t see this:
    We noticed your tunnel is having issues. This may be due to intermittent problems with our tunnel provider. If you have trouble connecting to your app, try to Restart the project, or switch Host to LAN.
  • Do you have some giant file or asset in your project somewhere, if so this could be taking forever to load and the process times out.

Hi Bacon,

Will check, thanks!.

1 Like

Hi there, thanks for your help, apparently had something to do with the LAN like bacon said.

Once again thank you very much, you can close this ticket if you like.


1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.