Stuck at Downloading JavaScript bundle 100.0%

hi everyone,

i somehow managed to break my expo project. i installed a npm package (redux-thunk), added some lines in my root component - now it is stuck at „downloading JavaScript bundle 100.0%“; no errors.

i did a git hard reset, rm -rf node_modules, updated to sdk 21, tried it both on simulator and device via tunnel and lan, xde and cli.

any advice on what might cause this is highly appreciated, thank you!!

Did you try to remove that some line of codes you added in and see your problem still persist? if the problem is solved, that some line of codes is the source of error.

hi tanvi,

thanks for your reply. yes, i did a git reset to a previous version that was working, problem persists.

This is most likely some kind of infinite loop that your app is getting itself into.

I would definitely strip your app down to it’s barebones – just render a small thing at the root. Gradually add back components and basically perform a binary search across your codebase for the issue (adding logs anywhere you might need).


skevy, thank you. rebuilding it bit by bit led me to the line that was causing the loop. still not sure what the actual problem is (line is just a simple async function), but i’ll figure it out. cheers

Skevy, thank you, follow your advice I find the infinite loop. Never a good idea of using while loop in js.

Happens to me with the example from: GitHub - expo/expo-three-ar: Utilities for using Expo AR with THREE.js

1 Like

In ios you can Erase all content and settings

1 Like

I had the same issue on my physical iphone 10, and I got it working again by deleting the expo client app and installing it

I 've done pretty much everything and still, expo gives me hard times with being stuck on “Downloading JavaScript bundle 100.0%”.
I am gradually losing my mind and tremendously frustrated. Help! Any ideas?

edit: ok, got it
I am using expo SDK 37 so
instead of:
“react-native”: “”,
I had:
“react-native”: “0.62.2”

1 Like

Hi, I m also facing the same issue here, see:

I tried to uninstall expo and then reinstall it but no luck, I also tried to uninstall node and reinstall everything but still no luck even I tried creating a blank new project in expo and then serve it but it still not working
Please help!


I haven’t had time to work on any of my Expo apps lately but a few days ago I updated expo-cli and also various other stuff from Homebrew and after that was getting some weird behaviour from watchman.

See if you have a watchman process running, possibly using up a large amount of CPU. Try killing it to see if that makes a difference. When I killed watchman I got an error printed to the console which was something about falling back to a different method and then things suddenly worked. But unfortunately I wasn’t able to actually figure out what was wrong with watchman or how to fix it permanently.

Thanks for replying, can you please explain what is watchman and how can I close it?

watchman is something that expo (or Metro bundler?) runs automatically to watch which of your files have changed while you are developing.

Are you running macOS? Or Windows? I am not sure that Expo uses watchman on anything other than macOS.

If you’re running macOS you should be able to find watchman by starting the Activity Monitor (in /Applications/Utilities), selecting it and clicking on the octagonal “x” button on the top left.

If it is watchman that’s causing your problems you might find the value in the CPU column is high.

I am using in window 10, I don’t know why and how this error was occur to me but now it’s automatically suddenly working. I am thankful to you for your valuable response.

1 Like

Did you by now realize, where the problem could be? Facing same problem here

I am also facing the same issue ; did you overcome it ?

Hey did you figure it out, I too have tried everything… i faced this issue a week back, started working randomly after a day and now I’m stuck again for the past 3 days…

This issue happens on latest version of expo sdk 38 and only on Android,

How to work it around?

Open the expo menu and close it.

How to fix it permanently?

I’d love if you tell me expo team.

I was running into this issue, and this did the trick