Is it possible to use a Personal Apple Developer account with EAS build in a team setting?

We have published the first preview version of an expo app under my company Apple Developer account. We would like to switch the to the Personal Developer account of my colleague. He has already configured eas credentials, and we can see the Apple Distribution Certificate and Push Keys under his Apple Team ID in the expo portal.

However, when I try to create a new build with eas build --platform ios, then I get the following error:

:heavy_check_mark: Logged in and verified
:heavy_check_mark: Select a Provider › COLLEAGUES_TEAM (19xxx2)
:heavy_check_mark: Switched to provider: COLLEAGUES_TEAM (19xxx2)
:heavy_multiplication_x: The bundle identifier is not available to team “MY_COMPANY_TEAM (Company/Organization)” (3CXXXXXNF), change it in your app config and try again.
An attribute in the provided entity has invalid value - An App ID with Identifier ‘’ is not available. Please enter a different string.
Error: build command failed.

I tried removed my apple eas cookie and logged in again. I also tried to set EXPO_APPLE_TEAM_ID="WQxxx8K" (my collegues ID, both as an env variable as well as within eas.json, it’s picked up by eas build but somehow ignored.

Is this even possible? Or am I doing something wrongly?

hi there!

can you try deleting ~/.app-store and running the command again? also, you can skip this prompt entirely with eas build --non-interactive to just use the stored credentials

Hi Brent,

I deleted ~/.app-store and tried to build again, but it’s still the same after I log in with my Apple credentials. While the command initialy prints out Loaded "env" configuration for the "preview" profile: EXPO_APPLE_TEAM_ID. it will automatically pick my team and then fail, because the selected bundleID is not available for my team.

My colleague can run expo build successfully. He also gave me permission on AppStoreConnect on the app, but that didn’t help.

So I’m still wondering, if this is possible at all, or if team collaboration (multiple devs running EAS builds) is only possible with an organization Apple Developer account.

It is not required to have an organization account. See Apple Developer Program Roles - Support - Apple Developer for a list of roles and their associated permissions. If you want to be able to manage provisioning profile / certificates, which is what authenticating in EAS CLI here is for (you can skip that with --non-interactive to use the most recently stored version), then you need to be an app manager. For certain privileges, such as to generate an ASC API key, you need the admin or account holder role.

1 Like

Thank you for the clarification! I didn’t understand, that ‘–non-interactive’ would make a difference in how certificates are handled, I thought this would just skip the prompts (not sure this is actually documented somewhere).

So running with ‘–non-interactive’ produced the error “Distribution Certificate is not validated for non-interactive builds”. My colleague (owner of the Apple Dev account) now submitted a new build again and now it works for me in --non-interactive mode.

Thank you for your help!

1 Like

yeah i think you’re right that this isn’t adequately documented!

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.