iOS build fails: Possibility to get detailed error message?

The android build succeeded, but the iOS build failed with the following message:

[exp] Validating distribution certificate...
[exp] Error validating credentials. You may need to clear them (with `-c`) and try again.
[exp] Unable to validate credentials. Request ID 3e3c27c0-d610-11e7-b205-fdfbd36812ab, message: Internal error occurred. Please try again in a few minutes or contact support.

Can you provide a more detailed error? Thanks you very much for any help on that.

Hi, it looks like we were unable to validate your Apple certificate. Usually this means:

  • Temporary outage on Apple’s side
  • Problem with certs/accounts (sometimes fixed by revoking and clearing)


thank you for your quick reply. Can you tell me what exactly did not work, e.g. creating an App ID, load certificate, …?


hey @dome-ger, could you provide your build-id? This is different from request id and will help us get more info.

Hi @quinlanj,

unfortunately I don’t get to the step to see a build ID, as the validation of the credentials fails before starting the actual build I guess.

Best, Dominic

Does the process try to create an App ID or something like this? What are the steps? Maybe this helps to resolve my problem.

@dome-ger We do try to create an App ID I believe. You also must have a paid developer account in order to create apps for the App Store.

Since it appears your iOS build on Expo and your Apple Developer account may be in a state we’re not handling well, could you clear the configuration and try again from the beginning?

Clearing your state

To clear your iOS app certificates on Expo, run exp build:ios -c.

To clear your Apple Developer center App ID, certificates, and provisioning profiles, visit:
Sign In - Apple (distribution and push certs)
Sign In - Apple (provisioning profiles)
Sign In - Apple (App IDs)

Build instructions

Be sure to follow the instructions here very carefully, each step is important:

You also can try a new option to request the certs and provisioning profiles from your computer (instead of our build machines), explained here: This option is new, though, so I’d recommend trying the more stable steps in the docs instead.

Getting more debug info

We don’t yet have a way automatically get the debug logs (we know it’s important, though) and we need a build ID like “3e3c27c0-d610-11e7-b205-fdfbd36812ab” to look up the logs for you.

Hi @ide,

thanks for your help. Seems like I didn’t have the permission to create another App ID or Certificate so that might be the reason why it failed. I tried out another account and it worked perfectly.

1 Like