InvalidCredentials upon sending push notification to standalone iOS app

Hey guys! :wave:
I’m having some issues to make push notifications to properly work on my iOS standalone app.

I have double checked that the apns cert is the right one and it’s valid (not revoked or expired), although I’m getting a InvalidCredentials error when trying to deliver a push notification.

I’ve deleted all the existing push certs I had on my Keychain, then I ran exp fetch:ios:certs to fetch the ones that Expo is using, and finally re-imported that to my keychain. The bundle identifier is the correct one, the expiration date is next year, I also went to the apple developer portal and it wasn’t revoked either. But it didn’t worked.

So… I started a new build from scratch, deleting the old certs, and now letting Expo to handle everything… and it’s failing with the exact same error :disappointed:
HELP PLEASE!!! I’m one week from the launch date and I need this thing working :sweat:
I saw there’s some entries about this problem in the forum, but even I tried everything it isn’t working as expected.

The build url is:
I can share any other useful information you might need to help me with this

Thanks in advance!

Hi @atmarketplace! So sorry you’re having trouble. I’m tagging @ide who knows everything (!) about push notifications

1 Like

Expo’s encrypted credentials database & cache don’t contain any iOS entry for the app linked from your build URL. You will need to provide new credentials. Make sure you have the latest version of exp, which does the work of provisioning your push credentials and uploading them to Expo (the build logs won’t show anything related to push credentials since this is mostly handled on your computer).

Hi @ide

That’s because yesterday I decided to start from scratch trying better lucky
I’m not with my computer right now, and trying to access to doesn’t work now (our code broke message)
If you can check the latest iOS build for this project you’ll see the certs:

Thanks in advance

Hey @ide, this is the build URL:

@ide @schazers suddenly after a whole day failing with InvalidCredentials error, it started working properly :man_shrugging:
Thanks for your help! :slight_smile:

1 Like


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.