Invalid JKS Keystore: Invalid keystore format

I am trying to upload a new signing certificate to our project. I used Google’s instructions to generate a new keystore via the Android Studio > Build > Generate UI.

When I try to upload the resulting keystore to Expo’s certificate screen, I get the error message “Invalid JKS Keystore: Invalid keystore format” in red after clicking save.

I’ve also tried creating a new key via the key tool command, and that’s resulting in the same error.

I’m on a M1 Mac.

I think You may corrupt the file during copy/transfer. Are you using maven? If you are copying keystore file with “filter=true”, you may corrupt the file. Please check the file size.

I’m using the Expo web UI to upload the file. No command line or use of maven.

Hey @travisconnectourkids,

Can your provide such as are you using EAS build or classic builds? If you are using classic build, you can expo build:android --clear-credential and retry?

Or, if you are using EAS, run eas credentials please share the output or any error message you get here in case that doesn’t work.

I’m just using the Expo web UI for managing credentials in the project. Not using the expo or eas command line.