I get error message “Could not find target in project.pbxproj” when executing eas build -p ios

  • Bare workflow
  • EAS CLI = 0.48.2
  • Expo = 43.0.0

I can build with “eas build -p android” but I can’t build and get the error message below when I run “eas build -p ios”. I have several other applications and the same errors occur and I can’t build.

$ eas build -p ios
✔ Linked to project @...../AppName (​https://expo.dev/accounts/...../projects/AppName)
    Error: Could not find target '2' in project.pbxproj
  • I used to use Management workflow and at that time I can run both android and ios with expo build.
  • I ran eject Management workflow to Bare workflow since I wanted to deploy a billing system.
  • Before running eject I was using EAS build, and at that time I could build android but not ios. I think I got similar error messages even though the timing that I got error messages was different.
  • eas submit works fine for both android and ios.

I suspect that the Local Step 3 is not working but I am not sure how to setup.
iOS build process

I would appreciate it if anyone could give me any suggestions.

Hey @atsuhikonakamura, could you try creating a brand new project via expo init -t bare-minimum and then run the eas config steps and finally see if the same error occurs when trying to build?

Thank you for your prompt reply.
And thank you for your precise instructions.

I ran the command based on your suggestion and I was able to build.
I have searched for a cause and I could identify it as well.

The cause was simple, I was using a Japanese name (or term) for expo.name within app.json. I have modified it to alphabet and then I could build by running eject again.

I have been concerned about it for a month but now it has been resolved.
Thank you very much again for helping me for this even if it was such an introductory thing.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.