I can't update my app

Hello again,
I am testing the expo-updates in my app after solving the issue with the env variables during the building process ( Can't communicate with the server ( i presume a issue with env environment) - #8 by pasteles)

I’m following this part of the documentation Release Channels - Expo Documentation.

First, i pushed my code in production releasechannel with expo publish --release-channel production

This is my eas.json

  "cli": {
    "version": ">= 0.38.3"
  },
  "build": {
    "development": {
      "releaseChannel": "development",
      "developmentClient": true,
      "distribution": "internal",
      "env": {
        "RELEASE_CHANNEL": "development"
      }
    },
    "production": {
      "releaseChannel": "production",
      "android": {
        "buildType": "apk"
      },
      "env": {
        "RELEASE_CHANNEL": "production"
      }
    }
  },
  "submit": {
    "production": {}
  }
}

And the output of expo publish:history

then i run eas build --profile production where everything was fine and installed the apkfile into my android device

For testing purposes, i added a text on my home screen and i would like to see in my standalone app in my android. After the change, i run the command expo publish --release-channel production in order to update this release channel, but nothing has changed in my standalone app.

I thought it was maybe because i didn’t commit the changes and i didn’t up the version so i did but i can’t see any change in my home screen into my standalone app after that so i don’t know what can i do

do you change the app slug depending on the profile?

also, you may need to open your app, wait a few seconds, then close and reopen it to get the update - this is because by default updates are downloaded async in the background

Thank you for your answer. I was a little impatient, it works nice,

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.