getDocumentAsync crashing Expo Client on iOS device after v39 upgrade


I have an app that uses the getDocumentAsync function from expo-document-picker (running 8.4.0) that worked perfectly across all devices in the Expo client when running under v38.

After upgrading to Expo v39 the call to getDocumentAsync immediately crashes the Expo Client (it doesn’t show the document picker), this only appears to happen on a real iOS device though as the iOS simulator and both android emulator and real devices work ok still.

I’ve got ‘usesIcloudStorage’ in my app.json so I don’t think that’s what is causing this, I haven’t been able to verify behaviour once the app is built to standalone unfortunately.

Has anyone had this issue in the Expo Client under v39? I use my iPhone for development so this is a big blocker to my workflow.

can you post a mcve?

Yep my bad, here’s a snack with an example

Press the pick a document button in Expo client on real iOS device and it’ll crash

I think this is related to iOS 14, just ran that snack on a real iOS 13.7 device and it didn’t crash

It is not since I had no issues on iOS 14 before upgrading to SDK 39.

Yep, my v38 version of my app works fine.

It’s the combination of expo-document-picker 8.4.0, iOS 14 and Expo 39 that crashes. I had initially assumed it was just v39 that caused the crash but as it worked on the 13.7 iOS device I wanted to add a note to say that it’s only iOS 14 that’s affected.