Expokit 36 Android app hanging on splash screen for one user- any ideas?

We have a single user who cannot run our ExpoKit 36 app. It shows the splash screen and just stays there.

What I know:

  • The phone: Samsung Galaxy J2 Pure. This appears to be an Android Go phone running either Android 8.1 or 9. Extremely low-end, probably has only 1 GB of RAM.

  • There was a crash reported to Play Store Console a few days before we got the help ticket for a Galaxy J2 Pure running Android 9.0. Not a lot of info, but the error from console:

Caused by: java.lang.RuntimeException: 
  at host.exp.exponent.experience.a$b.run (BaseExperienceActivity.java:7)
  at android.app.Activity.runOnUiThread (Activity.java:6424)
  at host.exp.exponent.experience.a.k (BaseExperienceActivity.java:2)
  at host.exp.exponent.experience.a.onResume (BaseExperienceActivity.java:5)
  at host.exp.exponent.experience.ExperienceActivity.onResume (ExperienceActivity.java:1)
  at android.app.Instrumentation.callActivityOnResume (Instrumentation.java:1416)
  at android.app.Activity.performResume (Activity.java:7630)
  at android.app.ActivityThread.performResumeActivity (ActivityThread.java:4054)
  • So it seems possible that this user had a crash originally and after that the app kept hanging.

  • We’ve had the user try all the app troubleshooting steps recommended by Samsung (https://www.samsung.com/au/support/mobile-devices/app-crashing/) except the more technical “clear cache partition” option. So, uninstall reinstall, clear data, etc.

  • We use the default options for OTA updates, so it tries to grab latest with a 30 second timeout.


  1. Anyone seen anything like this?
  2. The crash and then the hang has me wondering if something went bad with an OTA update. But I thought clearing app data would reset that. Anything else the user should try?
  3. Anyone have any trouble with their Expo apps and Android Go (https://www.android.com/versions/go-edition/)? The size of the average Expo app is obviously outside their normal recommendations, but I ran my app in profiler on an AVD with 1 GB RAM and didn’t see any issues.


apparently after trying all those steps AND rebooting one more time, the app finally worked. Who knows!

Nevermind- it sounds like the app is messed up again. REALLY starting to wonder about these Android Go phones…

Hi. A bad OTA update was also what came to mind, but in my experience, clearing the data does fix that. Also, I have only seen it result in an immediate crash on subsequent attempts, rather than a hang.

1 Like

Thanks for sharing your experience on a bad update- it’s been a while since I’ve seen one so was second-guessing what happened there. Our latest thinking is that something is messed up with the user’s cellular connection and they weren’t using wifi. With OTA updates happening at that point, just hanging on the splash like that seems like it could be associated with a really slow or constantly dropping connection, though I thought those would time out.

My experience was with a managed app but I imagine it’s similar.

I experienced the effects of a bad update when I was outside with a weak wifi signal. I was later able to reproduce it by repeatedly starting the app and closing it after a couple of seconds and clearing the data. After a few times it started crashing like this repeatedly on start until I cleared the data.

You can simulate a truncated update by hosting a truncated bundle yourself.

No idea if there’s a timeout for the OTA download :thinking:

I should try this again with SDK 37. In theory the OTA changes should have fixed this.

I remember having a similar issue with one specific android, it was caused by the splash screen resolution and the configuration in app.json, solved using
“splash”: {
“resizeMode”: “contain”,