.apk runs on genymotion but not device

Moved from here: https://github.com/expo/expo/issues/1631

Yury, I’m not sure how to help without more information. You mentioned you’ve tried previous suggestions. Can you list what those are?
Did you ever have an .apk build running on your device, and it only stopped working this time? Or was the splash screen always frozen on the device across all of your efforts?
What’s the phone’s OS version?

@schazers Hello!
I tried solutions from there https://github.com/expo/expo/issues/1226 and they didn’t help me.
As I said before , the apk works well with genymotion and works fine on ios with expo client.
Yeah, the app always was frozen on Samsung J7 pro.
Unfortunately, I don’t have another physical android phone to check the apk.

frozen splash screen on your device is probably a red herring, please see https://docs.expo.io/versions/v26.0.0/workflow/logging#view-logs-from-android-device-or-emulator to learn how to view your raw device logs and then take a look at what errors you’re encountering specifically. let us know what you find or feel free to even just dump your full logs here from the time when you app is closed to when it’s open and you’d have expected the splash screen to be dismissed

@notbrent Thanks. I will try do that.
@schazers I forgot to say, android version is 7.0. May be it can help .

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.