Expo Web is not working

Hey there,
Expo Web is causing BIG problems for me.

I wanted to try it out and made a new app with Expo init.
Just added a Button and TextInput.
Then I ran it in an Emulator without any Problem.

However running it in Web caused a lot of damage.

First of all when I run it in Web it immediatly crashes my VS Code and obviously it does not continue to load or run becuase the terminal gets closed.

Another thing happening is that after that crash I am not able to run expo start anymore… it says that the access for running node.exe are blocked for some reason…

Another thing happening is that the app.js where I placed my testcode is deleted and cannot be restored with Git for example… AND I cannot create a new App.js file because that is also not permitted…

Basically I cannot do anything now.

Expo diagnostics:

  Expo CLI 3.25.1 environment info:
      OS: Windows 10
      npm: 6.14.5 - C:\Program Files\nodejs\npm.CMD
      Android Studio: Version AI-191.8026.42.35.6010548

So I just tried it a second time and it again closed my VS Code and also deleted my JavaScript File where my code was living… this time I named it New.js and imported in AppEntry.js but this “New” File also gets deleted!

This is a very very serious problem since it can destroy your work that you have done completely … ! :zap: :stop_sign:

I still cant use expo start or npm start … Error on npm start is access denied and on expo start:

Fehler beim Ausführen des Programms "node.exe": Zugriff verweigertIn C:\Dev\npm\npm\expo.ps1:15 Zeichen:3
+   & "node$exe"  "$basedir/node_modules/expo-cli/bin/expo.js" $args
+   ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~.
In C:\Dev\npm\npm\expo.ps1:15 Zeichen:3
+   & "node$exe"  "$basedir/node_modules/expo-cli/bin/expo.js" $args
+   ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : ResourceUnavailable: (:) [], ApplicationFailedException
    + FullyQualifiedErrorId : NativeCommandFailed

Okay it seems like my Bitdefender is deleting the files…

Yikes. Hope you didn’t lose anything too substantial @yesiamfaded. Thanks for sharing your findings. Hopefully others using Bitdefender can take note.


1 Like

Yes its definitly Bitdefenders fault… because it deletes files and also blocks node execution in some cases.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.