Expo not connecting to development server

HI there!
I’ve been using Expo to run my react-native projects, but recently i’ve run into problems where expo says it can’t connect to the development server.
It says my tunnel is created, but every time it starts building my JavaScript bundle it doesn’t load.
Thanks in advance!

Hi! Are you able to load your project’s development URL from your phone’s browser?

Thanks for the quick response!
When I try to run the app from my phone, it starts building the JavaScript bundle, but then gives me an error message that it can’t can’t connect to the development server.

Interesting! Do you have a screenshot of the error message? This can happen in a few potential places.


Thanks again for being so helpful and responsive!


OK. Can you try a few things for me?

  • restart the desktop-side devtool (xde,exp,crna), if you’re feeling aggressive restarting your computer may not be a bad idea
  • fully restart the expo app
  • confirm that the error is still happening
  • if it’s still happening, can you try to open your dev server URL in your phone’s browser? you should see some reply from the server, even if its an error
  • if that shows up correctly in your browser, can you try copying the error from that redbox, extracting the URL, and opening that in your phone’s browser?
  • if that doesn’t load, can you try removing the assetPlugin query param from the URL and retrying?

Let me know how this goes!


I’m not entirely sure how to access my URL as I’m still fairly new to this.
Tried the first three and it’s still happening, how exactly do I go about the last three?

If you use the “send sms” feature in XDE, you can copy/paste the URL without the exp:// portion and paste it into your browser, should work.

This is probably super annoying for you, but it wasn’t able to reach the site. The dev server url loaded just fine on my phone, but the server on the error message didn’t load even when I removed the assetPlugIn query…
Sorry for the constatn badgering, but really appreciate it

OK, that’s interesting. Are you on any sort of corporate or other heavily firewalled network?

I’m not. Just working from my room with no real restrictions.
Also, I tried again to run npm start from the app folder, and it told me that it’s missing the script. Any chance that may have somtehing to do with it?

Interesting. What version of npm are you using? Could you try installing your project deps with yarn?

Using npm 6.1, and when I tried to run it with Yarn, I was met with this lovely message.

Thanks again for taking the time

Not sure if it makes a difference, but every time I try to run it now, it builds up to about 60% then crashes…

Interesting! It seems like the directory you’re working in may have been originally created by an admin account, but you’re running this as a regular user? Can you delete node_modules entirely and try again?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.