EXPO GO crashes

After launching the Expo GO app from the QR code, it crashes and I can’t check the app screen under development.

Does below commands work?

# for android
expo start --android

# for ios
expo start --ios

Hi @masa5611

Does it do that with a newly created app? Or only with an app that you have already been working on?

Did it work previously and just started crashing now? If so, you could try checking if some recent change was the cause of the crashes.

Ideally, Expo Go would not crash, but there are certain things that will cause it to crash. e.g. if you have a style with an invalid value, like <Text style={{width: "crash!"}}>

The device logs might give you more information.

I have the same problem, didn’t change anything in my project, just updated expo go (I’ve been working on my project since 2 months ago). After updating expo go today, it started to crash. It doesn’t even give an error, just close when reach 100%. Opens normally on web, so the problem isn’t in the project.


Same problem here since the morning after updating expo go, the only app that dosent crash is a new one from scratch, my old project the day before was running fine now crash when 100% of download. There is something that we can do?

1 Like

I have the same problem. It was working yesterday but it doesn’t work since this morning (The same project. I also tried other projects but the app doesn’t open any project not even snack.expo.dev examples.

1 Like

I have the same issue. As soon as my Expo Go app was updated on Android, I can’t open any existing projects. Stuck

1 Like

I have same issue. I am using expo go v2.25.2 on emulator and it is working normally. But I and my friend use the updated expo go v2.26.2 and my app bundling but crushing while downloading.
It is perfectly workind before the update to v2.26.2.

Hi all. Can someone please get the device logs to see what the error is?

Exact same for me.

As far as I can see, there are no errors logged. The build process looks okay (Android Bundling complete…) but the Expo client app crashes w/o any error messages or warnings, just restarts

There should be at least something in the Android logs if you run adb logcat. Please can you have a look at paste anything here that looks like it might be relevant?

The problem was solved with the new version 2.26.3. Thank you for your interest.

1 Like

Great! I was just was just going to suggest that because I saw it had been released.

1 Like