expo-cli 3.0.9 emulator expo client shows error(network response timeout or packager is not running)

Dear Developers,

After I upgrade my expo-cli to latest version 3.0.9, my nox emulator shows network response timeout. Error log shows uncaught error java net sockettimeoutexception. I spent 5 hours on this problem. I did try 3 different version of expo client apk, they shows same error. In my real device it runs fine. I assumed it is my pc network issue, I tried reset my network environment, port rule in my firewall setting etc, and reinstall my nox emulator, still not working. I tried android emulator as well, but it shows different error which is Packager is not running at balabalabala. Finally, I downgrade my expo-cli to version 3.0.2, problem solved.

Any idea for this?

Update, problem come out again, it might be something wrong regarding to my vpn, but it works perfectly previously without vpn. I need to keep investigating.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.