Expo Go client returns network timeout error

I get a network timeout error when i try to connect to my dev server using the expo go client android app i tried the solutions that are suggested in other threads but they don’t seem to work for me i tried

1.Allowing the port in inbound rules in firewall, and even tried turning it off completely
2.Made sure im on the same network
3.Tried previous versions of expo client app
4.Tried connecting using virtual device/simulator
5.Tried tunnel(although this immediately switches back to lan) and local
6.Turned off windows defender
7. Created and tried on a new project
8. I even wanted this so much that i had to try snack in browser but i have to wait in some sort of queue to see changes, which takes a lot of time.

Is there any option left?
thanks in advance.

Hey @kaleb-kb, sorry you’re encountering difficulties getting this up and running with Expo Go. To clarify, are you saying that attempting to connect via an Android Emulator also times out? Also, can you run npx expo-env-info and share what it prints out?

yes it also times out on an Android Emulator
npx expo-env-info text prints out:

expo-env-info 1.0.2 environment info:
OS: Windows 10 10.0.19043
Node: 16.6.2 - C:\Program Files\nodejs\node.EXE
npm: 7.20.3 - C:\Program Files\nodejs\npm.CMD
Android Studio: Version 2021.1.0.0 AI-211.7628.21.2111.8309675
Expo Workflow: managed

I also have the same issue. Upon running the emulator with Connection mode set as “Local”, it works for the first time. But afterwards I get a Network response timeout error.
In the logs, the error is java.net.sockettimeoutexception: timeout.
My expo environment info is:
expo-env-info 1.0.3 environment info:
OS: Windows 10 10.0.19044
Node: 16.13.1 - C:\Program Files\nodejs\node.EXE
npm: 8.3.0 - C:\Program Files\nodejs\npm.CMD
expo: ^43.0.3 => 43.0.4
react: ^17.0.1 => 17.0.1
react-dom: ^17.0.1 => 17.0.2
react-native: ^0.64.3 => 0.64.3
react-native-web: ^0.17.5 => 0.17.5
Expo Workflow: managed