Build:ios - cant authenticate with Apple Developer Portal


I’m trying to build my app for iOS using expo-cli 2.7.2-alpha.1. And after i enter my apple ID and password, i’m receiving Authentication with Apple Developer Portal failed!
I can log in to with the same credentials. This is an agent account, so on membership screen there is

  • Entity Type - Company / Organization
  • Your Role - Agent

There is also a certificate in Certificates, Identifiers & Profiles → iOS → Development

What could possibly cause this?

I used expo-cli 2.4.0 before and there also was an error, but even with debug on it showed [object Object], so i cant tell is it the same case.

Hey @ilior,

It looks like we accidentally released an alpha tag. Can you try running yarn global add expo-cli or npm if you use that, and attempt to build with expo-cli version 2.7.1?


1 Like

Hi Adam

Unfortunately, rolling back to 2.7.1 has no effect.
Is it possible to start build from expo website or any other means besides expo-cli?

It seems to be issue with my PC. I tried building from exact same files, including node_modules, on another PC with newly installed ubuntu and expo-cli and it works fine

May be it is related to DNS? What adress do expo-cli use to authenticate with Apple?

I’m currently having the same issue with the latest expo-cli

1 Like

Same issue here:

× Authentication with Apple Developer Portal failed!
[09:28:49] Process exited with non-zero code: 2
[09:28:49] Error: Process exited with non-zero code: 2

at ChildProcess.child.on (C:\Users*\AppData\Roaming\npm\node_modules\expo-cli\node_modules@expo\spawn-async\build\spawnAsync.js:39:21)
at emitTwo (events.js:126:13)
at ChildProcess.emit (events.js:214:7)
at ChildProcess.cp.emit (C:\Users*
at maybeClose (internal/child_process.js:925:16)
at Process.ChildProcess._handle.onexit (internal/child_process.js:209:5)

Same issue here,
“expo-cli”: “^2.10.1”,

tried the expo build:ios and got this errror

Trying to authenticate with Apple Developer Portal…?[2K?[1G?[?25h?[31m×?[39m Authentication with Apple Developer Portal failed!
?[31m[20:37:11]?[39m ?[31mProcess exited with non-zero code: 127?[39m
?[31m[20:37:11]?[39m ?[31m?[90mSet EXPO_DEBUG=true in your env to view the stack trace.?[31m?[39m

Anyone from the expo team can check on this? Are we only 5 persons on planet earth are having this issue?

1 Like


I see @timezoom that you are on windows, @iamrommel what about you? Is this first time you used build:ios command or it stopped working at some point? Did you followed all windows specific instruction in the documentation?

Windows users must have WSL enabled. We recommend picking Ubuntu from the Windows Store. Be sure to Launch Ubuntu at least once. After that, use an Admin powershell to run: Enable-WindowsOptionalFeature -Online -FeatureName Microsoft-Windows-Subsystem-Linux

Can you check if in your global node_modules there is package @expo/traveling-fastlane-linux?


As an update to my situation: after i successfully logged in and built IPA on another PC, expo build:ios is working fine on initial PC, without asking for Apple ID anymore

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.