Error running expo opt-in-google-play-signing

I’m having issues running the play store signing opt in from CLI: recipe for target 'Release/' failed
make: *** [Release/] Error 1
make: Leaving directory '/tmp/pty-tmp-install/node_modules/node-pty-prebuilt/build'
gyp ERR! build error
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:266:23)
gyp ERR! stack     at ChildProcess.emit (events.js:203:13)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:272:12)
gyp ERR! System Linux 4.4.0-18362-Microsoft
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild" "--build_v8_with_gn=false"
gyp ERR! cwd /tmp/pty-tmp-install/node_modules/node-pty-prebuilt
gyp ERR! node -v v12.7.0
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok
npm WARN pty-tmp-install@1.0.0 No description
npm WARN pty-tmp-install@1.0.0 No repository field.

npm ERR! errno 1
npm ERR! node-pty-prebuilt@0.7.6 install: `prebuild-install || node scripts/install.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the node-pty-prebuilt@0.7.6 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

It spits a whole bunch more out as well…too much to paste in. Any ideas?

Looks like ELIFECYCLE can happen for various reasons. e.g.: What does the ELIFECYCLE Node.js error mean? - Stack Overflow

Also various people suggesting to remove node_modules and running npm install or yarn again. :man_shrugging:

Thx, I must’ve tried running this thing atleast 20 times already, always the same result.

Here’s some more of what gets outputted:

/home/adam/.node-gyp/12.7.0/include/node/v8.h:2572:40: note:   candidate expects 1 argument, 0 provided
../src/unix/ error: no matching function for call to ‘v8::Value::IntegerValue()’
   winp.ws_row = info[1]->IntegerValue();

A whole bunch of this call to v8 errors

Ok, I got further than I have before. Had to install nvm and run an older version of node, version 8.x specifically…but now I get:

> node-pty-prebuilt@0.7.6 install /tmp/pty-tmp-install/node_modules/node-pty-prebuilt
> prebuild-install || node scripts/install.js

> node-pty-prebuilt@0.7.6 postinstall /tmp/pty-tmp-install/node_modules/node-pty-prebuilt
> node scripts/post-install.js

npm notice created a lockfile as package-lock.json. You should commit this file.
npm WARN pty-tmp-install@1.0.0 No description
npm WARN pty-tmp-install@1.0.0 No repository field.

+ node-pty-prebuilt@0.7.6
added 64 packages from 44 contributors and audited 109 packages in 4.465s
found 0 vulnerabilities

error { Error: read EIO
    at Pipe.onread (net.js:622:25) errno: 'EIO', code: 'EIO', syscall: 'read' }
Error: PEPK tool failed with return code Error: read EIO

So still stuck

This is not exactly the same error, but worth checking:

The error comes from the following block of code, so it’s definitely something to do with not being able to execute java -jar ...:

Thx for the response, but I dont think this is my issue. I’m pretty sure I have Java set up correctly:

echo $PATH
java -version
java version "1.8.0_201"
Java(TM) SE Runtime Environment (build 1.8.0_201-b09)
Java HotSpot(TM) 64-Bit Server VM (build 25.201-b09, mixed mode)

Eeny, meeny, miny, moe…which node version wins. I tried several, in the end v10.13.0 made everything work.

I tried v8.9.0, v8.16.1, and v12.4.0 and only the above version worked…posting in case anyone else stumbles onto the same issue.

@fanofskynyrd is right, using nodejs version 10.13.0 worked perfectly for me. Expo should update the documentation or better than this, support multiple versions of nodejs.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.