Hi, I am trying to opt into google’s-play signing using the following command:
I follow the prompts, provide the key. the process eventually stops when it fails to install
I tried installing the lib independently but failed, also tried installing older versions. I looked into their repo’s issues and got really discouraged. There are similar installation issues opened and w/o resolution. Doesn’t look like its being properly maintained.
Is there any way to go around this?
– Node12.0.0 - NPM 6.9 - Expo SDK33 –
I am using the following versions and it works fine. Maybe try to downgrade?
Expo CLI 3.0.8 environment info:
OS: macOS 10.14.4
Shell: 3.2.57 - /bin/bash
Node: 8.16.0 - /usr/local/opt/node@8/bin/node
npm: 6.4.1 - /usr/local/opt/node@8/bin/npm
Xcode: 10.2.1/10E1001 - /usr/bin/xcodebuild
expo: ^32.0.0 => 32.0.6
react: 16.5.0 => 16.5.0
react-native: https://github.com/expo/react-native/archive/sdk-32.0.0.tar.gz => 0.57.1
react-navigation: ^3.0.9 => 3.6.1
I’m experiencing a similar issue as fozzarelo. The process continues to fail on the install of the npm package and I can’t install the library manually.
Any help would be very much appreciated!
@nicholasbernard and @fozzarelo What version of
expo-cli are you running?
@charliecruzan I’m running 3.0.9
I’ve also tried downgrading to 3.0.8 like @theylooksotired has demonstrated, but same issues. node-pty-prebuilt just does not want to install.
theylooksotired is on expo32. I don’t think it’s a good idea to go back to 32 for many reasons. But the most relevant for this topic is that it won’t build 64bit.
For now, I would recommend staying on 33 and a recent cli but don’t use the ‘–type app-bundle’ option when building. This will give you a good old fashioned signed-apk on 64bit covering the August requirement.
No doubt Google will be requiring aabs soon, but not yet. And I am sure Expo’s team will have this solved by then.
charliecruzan As you can see I made a couple of assumptions here and there even ventured out a recommendation. Please correct me if I’m wrong.
This might have to do with your versions of Node? Since I’ve seen other builds of app bundles go successfully
Could you try on nodev10.16?
Won’t that bring compatibility issues? I’m pretty sure I had to go to Node12 when I upgraded my cli.
I’ll double check in the afternoon and report back.
Basically in the same boat here… curious as to if you ever resolved this
I didn’t solve it. Not a blocker for me so I moved on.
The august requirement was 64 bit, and that can be met without the --type app-bundle.
I’m sure i’ll have to to revisit this soon.
This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.