Error running expo init

Hi all,

Trying to get started using Expo but failing to initialise my first project.

Running expo init rummi produces the following error:

? Choose a template: blank
[06:57:28] Extracting project files...
./node_modules/lottie-react-native/docs/gifs/Community 2_3.gif: (Empty error message)
tar: Error exit delayed from previous errors.
Process exited with non-zero code: 1
[06:57:41] zlib: unexpected end of file
[06:57:41] Set EXPO_DEBUG=true in your env to view the stack trace.

Running Expo version 2.3.8, Node version 8.12.0, NPM version 4.6.1, on Mac OS Mojave.

Hey @azcn2503,

Are you still getting this error? I just ran expo init in my default environment (Node 10.13.0) and it worked as expected and then I tried with yours (8.12.0) and it worked as well. All our versions are the same as well.

If you’re still getting this error, can you run expo diagnostics and create an issue here:



Hi @adamjnav - it turns out I had a rogue issue with xcode and needed to do a reinstall. It all came back to life after that.

Good ole Xcode…glad you got it figured out!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.