Expo Init - getting stuck after npm WARN tar zlib: unexpected end of file

Hello, I have just started to build using react-native and expo. I have made sample projects using expo init before and everything worked smoothly. I am trying to create a new project using expo init and its getting stuck at exact same point everytime. i have upgraded expo-cli and tried a few things based on what is suggested in diff forums, none worked.

It always gets stuck after giving this warning zlib:unexpected end of file and this warning comes while extracting payments-stripe and lottie.

I have run expo diagnostics and following is what i got:

Expo CLI 2.6.14 environment info:
OS: Windows 10
npm: 6.5.0 - C:\Program Files\nodejs\npm.CMD
Android Studio Version AI-181.5540.7.32.5056338

flushing the npm cache worked.

Hey @findproject,

We’ve seen zlib errors occur as a result of running a version of node less than 10 so that may be another thing to consider if you run into this. Glad flushing the cache worked as well and thanks for sharing what worked for you.



This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.