Error: If you are running on the device, check if you have the right IP address in 'RCTWebSocketExecutor.m'

I get this message often on my expo app on iphone.

I often have this issue, anyone can help?

try re-running the whole show again.

Same here. It’s become quite annoying.

I restarted everything and the rror still doesn’t go away. Could you detail the steps that worked for you?

when i left from starbucks and went back home it worked, maybe try changing the network


Reinstall the XDE

I get this work, I had uninstall xde and the app and rerun again, I don;t know why, I reckon because of network or url link changing / unstable.

I’m glad I could help. Thank you me.

Looks like your app is running with prebuild bundle inside. Not loading it from local dev server. Try to clean build folders for your app to remove jsbundle from app.

Hi maksimko how to clean build folders my app to remove jsbundle from app? Where is build folders and where is jsbundle located?

If your phone cannot connect to your computer you may get this error. If this happens, make sure the developer server is running on your computer (you may want to click Restart in XDE or run exp r), force quit the Expo client app on your phone, and re-open your project.

The Chrome debugger also adds complexity since the JS needs to get loaded by Chrome and then send messages back and forth to your phone, so you could try disabling that too.

I don’t think this has to do with a cached JS bundle. Your phone can’t connect to the development server on your computer.

1 Like