Error: Couldn't get GCM token on device.]

Please provide the following:

  1. SDK Version: 37.0.0
  2. Platforms(Android/iOS/web/all): Android

I’m trying to get a notification token to use in Expo Notifications, but i’m getting the following error:

“Error: Couldn’t get GCM token on device”.
I’ve already tried to update expo-cli . I updated my SDK version and nothing works!
I did the expo login in Expo Client App and in terminal and nothing too.
I restart my PC, SmartPhone, clean cache and nothing want to work!
I configurate the firebase like this -> and nothing

i see all the probaly resolutions in forum and i try all, but no success.

I want to get a help.

1 Like

Same problem here. Did follow the steps in the Using FCM for Push Notifications guide. Did login into the expo app on the phone and expo cli but no result.

When i started to use Expo Notifications all was working pretty good. But yesterday started with this problem. And i don’t know how to solve. Every solution that i found leads to nothing!

Same for me. Everything seems to be configured correctly. When I run, expo push:android:show, I see my FCM API key. android.googleServicesFile is configured in app.json. There is no restriction for my key in Google Cloud Platform.

Possible solution:

I did a test with a standalone app now, where i generate a .apk file from expo platform.

So, i put a “alert” on my code to show the comportament of my application: i was trying to know if the expo can get the token.

Apparently it’s a problem with the development environment and when we generate a apk, the expo can get the notficiation token and this yellow box with the message is showed only in development ambient.

Solution: generate a standalone app (apk) and put a alert to check if is possible the get the token and put a response here.

I wish that every users can get this solution!

same problem continue for my app. i get exponent id two days ago but now token not see.
Warn: Couldn’t get GCM token on device

Solution : when install expo client android v 2.15.1 its working

you can install this link

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.